Meet - camera solution 640 x 480 instead of 1280 x 720?

Hello, we’re enjoying Jitsi Meet. All of a sudden my colleague started getting a lower resolution on their HP laptop. Has anyone experienced this? I am still getting Hi-res 1208 X 720, but his has gone down to 640 x 480. We’ve tried everything we can think of including checking the camera on HP, but when he accesses the camera through settings it looks fine there, only in Jitsi Meet. His internet is fine Chrome is fine, we’ve even removed permissions and reloaded to ask again, nothing seems to work. Anyone else who joins the meeting is fine in terms of their video resolution. Thank you so much!

is he connecting via VPN?

try to do an iperf test between the server and his end…

Or try this setting on

/etc/jitsi/meet/meet.mydomain.com-config.js

resolution: 720,
constraints: {
     video: {
        aspectRatio: 16 / 9,
        height: {
            ideal: 720,
            max: 720,
            min: 240
        }
     }
},
1 Like

Thank you so much for your response @masteryoda.

No we are not connecting via VPN. We don’t have our own server, we use the Jitsi Meet server. It’s very strange as we had a bigger meeting last night and everyone, apart from mobile attendees, had a full video screen except the teacher, who had on previous occasions not had a problem at all? It’s very strange indeed. See image attached.

can you ask him to try to install a different browser supporting webrtc, Firefox for example ? Sometimes it can be tricky to really remove all the settings for a site and if it works with Firefox it would make almost certain that it’s a problem with Chrome installation. If the problem is identifal with Firefox t’s very probably a network issue.

@gpatel-fr, thank you. Yes the same happens on Firefox. So we will delete Chrome and reinstall to see if that makes any difference. Thank you for the direction, much appreciated, will let you know the outcome. Best, M

Can you please check in the camera settings app, of the image is set to 4:3 or 16:9 (widescreen)

I’ve seen this in some Logitech webcams

Hello and thank you for all the advice and information. I wanted to update you on what we have found out so far.

  1. We looked at camera settings on the HP250 G7 and checked the drivers and they all look up to date. See image below.

  1. We tested the display in Zoom and it looked fine, full width display see image below.

  1. We also looked at the display by going into the camera app on the HP computer and that looked fine too. See image below.

  1. We then went into Jitsi Meet via Chrome and we still get the black bars.

  1. We tested the camera through webrtc.org and we got the following results.

  1. Details of the HP computer.

Screenshot 2020-04-23 at 12.31.24

Any ideas anyone?

same problem here, only with my logitech cam, built-in-cam works fine
i’m using chrome on Mac.
in firefox cam-display is fine.

@quichot, thank you so much for your experience. Our problem is with my colleague’s built-in camera.

I noticed today on our webinar other folks on laptops had exactly the same display, I guess it must be something unique to laptop displays?

Strange, because with my builtin webcam i don’t experience this issue.
I’ll keep searching what causes this “problem”, because it’s rather annoying.
So stay tuned :wink:

Thank you for your commitment, it is a very strange phenomena indeed. Because on Zoom his display looks okay, I can only assume it’s something in Jitsi Meet that is changing the display. If you find anything of course I am very interested to look in to it. Best, M

The overconstrained error ref in the test.webrtc.org page leads to this reddit page

it’s not very helpful but it says that:

`If you get an Overconstrained error, that typically means the webcam or camera device has settings that are not compatible with my code. With every camera being different (…)

and

Are there any special frame rates resolution set?

Maybe you can try to play with the camera setup. I don’t have this hardware myself.
Hope this helps

Thank you for that outstanding research. We will investigate further with the webcam in question. Best, M
:pray:

Actually, playing with cam settings does not resolve this problem.
Besides that, the camera works fine (both full height and width) in firefox
In chrome though i get black bars at both sides of the cam image.

With my built in camera of my macbook pro -> no problem
With my logitech cam’s with skype -> no problem
It only occurs with my logitech cam’s (type c920 and c525) AND chrome AND jitsi.

I don’t see any logic yet, but will keep searching :wink:

IMHO it stems from the fact that c920 & 525 transmit in 16:9

on my own instance if i set aspectRatio: 16 / 9, in my settings, the black bars go away.

can you please try the meeting on https://8x8.vc & check

Where exactly can i set aspectRatio @masteryoda?
Somewhere in /usr/share/jitsi-meet/interface_config.js ?
Because i only see a setting for thumbnails
LOCAL_THUMBNAIL_RATIO: 16 / 9, // 16:9
REMOTE_THUMBNAIL_RATIO: 1, // 1:1

try this setting on

/etc/jitsi/meet/meet.mydomain.com-config.js
under video section

please see my earlier reply

Great, thnx @masteryoda.
Now aspect ratio is correct and the black bars disappeared.
Probably the latest jitsi version introduced this specific issue in the combination chrome-jitsi and some webcam types.

Thanks a lot for your assistance

yes, you see this only in unstable versions… the stable version doesnt have this issue

@quichot and @masteryoda - looks like you guys solved it, but is that on a version on your own server?

So I opened a room on 8x8.vc and added the '/etc/jitsi/meet/meet.domain etc. after the url, but nothing happened. Obviously I’m doing something wrong. We are not running Jitsi on our own servers that would be one step too far for us now. See attached screenshot for your information.

Thanks!