Maximum client limitted to 12

we have configured jitsi meet on local server and its working perfect but when users connecting more than 12 its not allowing and users above 12 cannot connect to the server
my server configuration 32 GB RAM Intel® Xeon® CPU E5-2643 v4 @ 3.40GHz processor.
Is there any limiting parameters are there in jitsi, all componets in a single server vediobridge2
Please help me

still waiting for the comments

Could it be this? https://stackoverflow.com/questions/50361430/how-to-set-max-user-in-jitsi-room

my query is to users cannot enter the conference room more than 12 people

There is any document describing JVB performance tuning in Debian OS

My observation is that the client computers connecting to jvb run out of resources when having more than 10 users.

You can remove non-essential user interface options to make jitsi work better for 12 users and up.
If i would give you 4 options to reduce client CPU usage i would give you:

  1. Set default video resolution to 480
    in /etc/jitsi/meet/*-config.js
    reason, many users have reported success with up to 30 users by simply lower the video resolution: Bad audio quality and users dropping randomly, at ~25 users

  2. start the conference with video and audio muted.
    in /etc/jitsi/meet/*-config.js
    reason this allow people to host up to 120 users on one server: Maximum number of participants on a meeting on meet.jit.si server

  3. disable the blue “i am talking dots”
    in /etc/jitsi/meet/*-config.js
    disableAudioLevels: true,
    reason the added processing of AudioLevels takes too long time and cause missed audio updates hence bad audio quality for many users: Host a meeting with 500 people - ideas?

  4. disable the blurry video background
    in /usr/share/jitsi-meet/interface_config.js
    DISABLE_VIDEO_BACKGROUND: true,
    reason it may eat 28% CPU time for some users: Resolution Problem and CPU problem


By analyzing profile graphs on client side we have found some mac + chrome clients with non working hardware acceleration.
You can try disable the hardware accelerated H264 codec, because H264 still cause issues for some chrome mac users.

You have some more options to consider here:
Reducing resource usage to improve performance (both client-side and server-side)

8 Likes

Thank you so much for your response, will check

Very good compilation of such great Jitsi tweaks!
Thanks a lot!