Many complaints about video lagging behind audio also with p2p

Many of our users complain about video lagging behind audio also with p2p meetings with self-hosted Jitsi. I also encounter this myself quite regularly. Does anyone have an idea why this is happening? Any ideas on what to change?

Thanks!

try this in config file. Also, search the forum for this config and you’ll get some background

enableLipSync: false,

hi. Yes this value is already false (is the default…). But the variable suggests you should set it to true. But info on forum about what it should do is very limited, unless you found an insightfull post I missed?

Any updates in this issue?

This is an other issue where audio lags behind video (which would be very strange). This is the opposite; the video lags behind the audio…
Anyone?

Digging into this issue, I found several reports about wrong calculation of RTCP or JitterDelay by Chrome. See these threads:

In JANUS they found a fix and implemented it couple of weeks ago. See https://github.com/meetecho/janus-gateway/pull/2007

@saghul and @damencho; Is this something that could/should also be implemented in Jitsi? I think you were already trying this with the EnableLibSync bool, but not yet worked?

Looking forward to hearing your thoughts.

Regards,
Rick

Hey Rick!

I haven’t seen this myself lately. You should leave the lip-sync setting to disabled, at this point it can only do more harm than good.

If you see this in P2P mode too then there is no jitter adjustment in the server that can fix it, since the server is not used at all (I know you have TURN setup, so this is the case).

Thhat leaves the client side as the potential source. What browsers and versionss are you using? If you can reliably reproduce the problem, can you try a combination of browsers and see if that makes any difference?

We have one colleague with who we can easily reproduce, also on Jitsi. Interestingly with Firefox it does not happen but Firefox does switch back to a very low resolution (320p), while in Chrome it stays HD… His bitrate is however 2000k+ up and down, so no connection issues… So might it be that high resolution (he has a 4k camera) needs too much time to be compressed to 1024p, which causes the sync issue in Chrome because it doesn’t check/sync the time stamp of the compressed video with the audio, while firefox notices this and therefore switches to low res because that is the only resolution that was casted soon enough with right timestap that aligns with voice or so…?..?

Let me know if you want to jump on a meeting to test, or need more info…

Regards,
Rick

What resolution have you configured your server to use? What webcam are you able to reproduce easier with?

The camera is a logitec Brio 4k (https://www.logitech.com/en-us/product/brio). It is also reproducible on meet.jit.si.

Let me know your thoughts!

Regards,
Rick

We btw get around 20-30 reports per day (out of the 40-50 daily negative feedback reports), in which people complain about desynced voices… So quite significant…

1 Like

I think this might be related to https://bugs.chromium.org/p/chromium/issues/detail?id=1035077&q=brio&can=1 (so CChrome M83 may help)

Or this: https://github.com/jitsi/jitsi-meet/issues/6689 then it would be on our turf.

Any chance you can test Chrome beta?