Make the user enter their name befor joining a meeting

I set up my own server for my Jitsi React App.
Since that the “Join meeting” Popup, where users have to enter their display name is missing.


How/Where can I fix that?


Did you disable the prejoin page in config.js ?

I did it like this:

return (
                domain = { 'xyz' }
                roomName = {meetingName}
                spinner = { renderSpinner }
                configOverwrite = {{
                    requireDisplayName: true,
                    prejoinPageEnabled: true,
                    startWithAudioMuted: true,
                    hideConferenceSubject: false
                onApiReady = { externalApi => handleApiReady(externalApi) }
                onReadyToClose = { handleReadyToClose }
                useStaging = { true }
                getIFrameRef = { handleJitsiIFrameRef1 } />

Try replacing prejoinPageEnabled with prejoinConfig: { enabled: true }

Unfortunately it does not change anything.

Can you share your config.js file?

hmm… I don’t have a config.js file. I orientated myself on the GitHub example:

How do I include this file best?

I thought you were using your own Jitsi Meet deployment, in that case config.js is in your server.

Thanks - that was the solution! =)