Make Dev gives grey screen

Hey Everyone,

When I use “make dev” it compiles successfully and it links to localhost, the home page works as well but when I launch a test call, all I see is a grey screen[see below].

This is the error provided in console of web browser:
2019-10-23T17:54:36.628Z [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: Strophe: request id 1.1 error 0 happened
at Object.i.Strophe.log (strophe.util.js:89)
at Object.error (strophe.js:2083)
at e.Bosh._onRequestStateChange (strophe.js:5569)
o @ Logger.js:154
Logger.js:154 2019-10-23T17:54:36.628Z [modules/xmpp/strophe.util.js] <Object.i.Strophe.log>: Strophe: request id 1.1 error 0 happened

Any ideas? Thanks in advance.

Are you running it from master? Are there more errors in the console log?

I am from master, it worked previously(around 2 weeks ago).

This is what my console looks like

This is really strange, that bosh is trying to use https://localhost/http-bind where it should be by default https://localhost:8080/http-bind. Do you have any changes? Are you testing with the default deployment from the source: https://github.com/jitsi/jitsi-meet/blob/master/webpack.config.js#L11?

I have not changed anything about the bosh, only made UI interface changes for what was needed for our set up. Is there a manual way of changing the bosh to bind the correct URL?

Can you do a clean checkout of master, run npm install and make dev and try again? Does it work? I tried locally and it works.

the clean checkout works, not sure what could have caused the error I am having, as I said it was working last time I was working with it

I am also getting this on my version when I run npm install, not sure if it an issue

WARNING in asset size limit: The following asset(s) exceed the recommended size limit (244 KiB).
This can impact web performance.
Assets:
lib-jitsi-meet.min.js (653 KiB)

WARNING in entrypoint size limit: The following entrypoint(s) combined asset size exceeds the recommended limit (244 KiB). This can impact web performance.
Entrypoints:
  lib-jitsi-meet (653 KiB)
      lib-jitsi-meet.min.js


WARNING in webpack performance recommendations:
You can limit the size of your bundles by using import() or require.ensure to lazy load some parts of your application.
For more info visit https://webpack.js.org/guides/code-splitting/

Nope, you can ignore this. So a change in your repo should be triggering, you can compare it …