Low CPU usage but keep Best video & Audio as possible?

Hello everyone, I am a music tutor from Taiwan, know nothing about computer theory at all, and English is not well too, so I will be very appreciate if someone could pay me more patient and explain detaily. :pensive:

Recently Taiwan is affected by Covid-19’s breakout, it’s hard to go outside and gathering, so I tried to change my way from teaching face to face to online class(90% is one on one).

I followed a step-by-step tutorials from Youtube, built a Jitsi meet server in Linode. When start online class, my student said their laptop is REALLY HOT and often causing crash after 30 min. My MacPro is quite good(i9 10900K), but still use 88%CPU, My student’s laptop runs over 100% most of the time.

Is there any suggestion by changing config.js true/false could help reducing CPU usage without sacrificing the Video and Audio Quality? As I need more detail to know where my student can get better or do clear demonstration for them.
I only change some setting to improve the Audio & Video quality and left other setting as default (Linode).
Thank a lot, I 'll try any suggestion with much appreciate.
If need more information just ask me :nerd_face: :nerd_face: :nerd_face:

Welcome to the forum.

Well, sending and receiving 1080p video will definitely create a demand on your system. Since these are music classes, I’d think that audio is more important than video. So you might want to consider taking the resolution down to 720p at most.

Also, make sure you don’t have too many things running on your computer while in a meeting. Videoconferencing of any type (and especially one that uses SFU technology) will place a demand on your system resources. In SFU, the processing is done on the client end, so you need to make sure the clients have resources available to handle that demand.

1 Like

What does SFU stand for here?

SFU (Selective Forwarding Unit)
My answer is trying another browser. Firefox can maybe solve this problem. You may have a look at hardware acceleration topic, this means using GPU for this kind of tasks. Maybe changing Chrome settings about hardware acceleration may solve this too.

2 Likes

Thank you. To be honest, I’ve not known anyone to have much luck running firefox with Jitsi, but if it fixes this, then great.

I would have thought lowering video resolution would be an idea, but also the frontend only accepting {n} participant video streams, or not decoding & rendering every frame should be another way (although compression using A/B (delta) frames may make this a pain, it seems like the only way to be predictable on this is to bound the workload, separately to the number of participants.

Much thank to all of you guys, I just wondering what else can I do after turn down video quality to 720p? I’ll give it a shoot no matter what it’s good for.
Maybe some additional functions e.g. disableAudioLevels but in other title like testing/Media/Recording/Misc/UI/Stats/Privacy/analytics/Local recording.

And I have some other questions:
1.Is P2P mode helps for steady the connection?
2.Which burns more CPU in theory? Connecting through JVB or P2P?
3.If p2p mode is working will it show in somewhere like upper left corner in this picture?


4.Is it necessary to set up a TURN server to make sure P2P will work?

Thank you all again. :nerd_face:

According to my experiences

The main CPU load comes from the audio/video processing. The load of the connection is negligible on the client side.

1 Like