Loss of participants, video and sounds crashs when 12+ attendees

Hi there,
i have the same problem since a few days and i did nothing other than update my server. Is there a incompatibylity between ubuntu 20.04 and jitsi? (Sorry, but my english isn’t very good)

These results are against meet.jit.si

Upon joining (1 person).

Upon 3rd person:

Im using ubuntu as well. Im not sure what meet.jit.si is running on (thats what Im testing against).

Also wanted to add Mac users pointed out they weren’t able to see anyone (sending me a screenshot of their browser only showing them and 3 black boxes), so it might related to Mac/iPhone (viewing on web browser)

Do you have bitwarden extension? Can you try disabling it and trying again? This is for the postis message error…

Something else is blocking the websocket connection its either some service or some extension is blocking that connection. You need to figure out what is that … Are you using some http proxy for your internet traffic or something?

I have Dropbox password. I’ll try on an incognito window across all 3 to see if it is an extension.

I have regular high speed internet and have also tried from a friends house using fiber internet. No proxy or VPN.

About the websocket close error:

Close Code 1006 is a special code that means the connection was closed abnormally (locally) by the browser implementation.

https://tools.ietf.org/html/rfc6455#section-7.4.1

do you use snap chromium ? That’s what I use to access Jitsi sites. Needless to say I don’t see websocket failures.
About meet.jit.si, everything is pointing at them using Ubuntu.
It’s true that an internet search is returning incompatibilities between Squid and websockets. I don’t think many people are still using Squid these days.
I looked at the Chromium Network tab and you can select on websocket queries (“WS”), is there a reply in your case and if yes can you post it ?

Was able to successfully run a chat with 5. I noticed on the cellphone the video of other users went black.
From the other users’ windows it said the video was cut from the mobile user to save bandwidth (?). Mobile and all others were on wifi. Mobile was using web browser.

As for Mac, I noticed briefly when trying to access the group chat using the direct link (from a 5th comp), the other users went black until I removed that comp. I saw this error

I see so it says the closure is abnormal, I agree.
Again I’m wondering how to overcome it. This is the last part of the project Im working on so I’ll test until this can be stable or there’s no more solutions.

The error from the last screenshot shows you were offline. Network changed {"isOnline": false}, this is chrome detecting that you don’t have internet connectivity.

OK. I retested to make sure.
I saw this on 2 of the 3 comps:

Ice failed means there is a network problem, if you cannot establish a websocket connection, I don’t expect and the fallback to turnserver using secure tcp connection to succeed. And apparently your network drops udp connection to the bridges … There is something in your network dropping all those …

Saw a post with the same error I was getting ([SOLVED] BridgeChannel.js:85 WebSocket connection to 'wss://localhost:8443/colibri-ws/ failed:).
Could these issue be related?

My docker image uses the latest docker jitsi. I haven’t changed the environment variables below this line:
#

# Advanced configuration options (you generally don't need to change these)

# 

# Internal XMPP domain

XMPP_DOMAIN=meet.jitsi

# Internal XMPP server

XMPP_SERVER=xmpp.meet.jitsi

# Internal XMPP server URL

XMPP_BOSH_URL_BASE=http://xmpp.meet.jitsi:5280

# Internal XMPP domain for authenticated services

XMPP_AUTH_DOMAIN=auth.meet.jitsi

# XMPP domain for the MUC

XMPP_MUC_DOMAIN=muc.meet.jitsi

# XMPP domain for the internal MUC used for jibri, jigasi and jvb pools

XMPP_INTERNAL_MUC_DOMAIN=internal-muc.meet.jitsi

# XMPP domain for unauthenticated users

XMPP_GUEST_DOMAIN=guest.meet.jitsi

Well having same issues with meet.jit.si points to network not your deployment …

Luckily the images I shared above shows the same error in both meet.jit.si and my local deploy.
I’ve tested 3 networks 7 devices.

I guess we can just write this off as a known issue. I’ll stay tuned to the releases, hopefully this can be fixed.

Hey @angrycoder Can you open a 3 way meeting with no VPN on 8x8.vc. See what is the experience of the participants, does it work? And you can just leave feedback using:
image
write in the feedback what you see …
Put something in the text mentioning me 'Hey damencho … ’ so I can spot it and see stats for your call and debug it.

You don’t need a subscription for 8x8.vc just open a meeting with a link, like 8x8.vc/angrycoderTestroom1 … from 3 browser(chrome preffered) tabs … or if you can do it from two devices …

I saw you started reporting issues in the docker repo, if meet.jit.si does not work for you, I don’t expect and your deployment to start working … there is something strange going on…

Tested twice and sent feedback. I think it might relate to lost connection. I waited thru the blackout period and noticed the screen came back eventually. Cell (chrome browser) was the weakest so it didn’t show too often.

I can accept that this is how it behaves with connection issues. I’ll continue on github for issue related to my own docker instance. Thanks for the help :slight_smile:

hi @damencho , not sure if this is related.
For the last 2-3 weeks we’ve seen a lot of drop-offs / disconnects in participants on meet.jit.si (the community). In every meeting this happens ~2-3 or even more times that a user is disconnected due to a websocket failure, here’s the console logs:

or in more detail below.
Is there a known bug with the websocketclosing on the community version?

invalid/:1 Failed to load resource: net::ERR_FAILED
​ WebSocket connection to 'wss://meet.jit.si/xmpp-websocket?room=2f0fde7537a47b47293391f4' failed: Data frame received after close
_connect @ strophe.umd.js:5463
invalid/:1 Failed to load resource: net::ERR_FAILED
contentscript.js:17 Uncaught TypeError: Cannot read property 'target' of null
  at o._onMessage (contentscript.js:17)
contentscript.js:17 Uncaught TypeError: Cannot read property 'target' of null
  at o._onMessage (contentscript.js:17)
contentscript.js:17 Uncaught TypeError: Cannot read property 'target' of null
  at o._onMessage (contentscript.js:17)
contentscript.js:17 Uncaught TypeError: Cannot read property 'target' of null
  at o._onMessage (contentscript.js:17)
contentscript.js:17 Uncaught TypeError: Cannot read property 'target' of null
  at o._onMessage (contentscript.js:17)
contentscript.js:17 Uncaught TypeError: Cannot read property 'target' of null
  at o._onMessage (contentscript.js:17)