Login ability to frontend

I have the basic Jitsi install done on an Ubuntu node.
Currently we can get to front end and start video conferences. What I have asked if there is a way to have the main jitsi interface be accessible via login either to main room that we have for daily call or to main page. I have been reading several posts on using OpenLDAP but none have worked.
So over all we want internal to have access only to the main and then have a guest access with no login so when we need to have video conference with clients etc… we can just send them the meeting link.
Are there any how to’s? I haven’t found any searching through the forums. Or is this even possible?

Thanks

You can do it by using JWT tokens. Setup a simple front page with login/pwd and pass jwt token via Jitsi API.

A much simpler approach might be to use the secured domain setup. Although everyone has access to the front page, a meeting won’t start until a Host joins the call. Host could be internal people only.

I am not sure what I did different but I have LDAP working now for my main URL - I now and trying to set up the guest URL.
I have updated
file - /etc/jitsi/meet/mydomain
hosts: {
// XMPP domain.
domain: ‘mydomain’,

    // When using authentication, domain for guest users.
    anonymousdomain: 'guest.mydomain',

file - /etc/prosody/conf.avail/mydomain.cfg.lua
VirtualHost “mydomain”
– enabled = false – Remove this line to enable this host
authentication = “ldap2”
– Note that old-style SSL on port 5223 only supports one certificate, and will always
– use the global one.
ssl = {
key = “/etc/prosody/certs/mydomain.key”;
certificate = “/etc/prosody/certs/mydomain.crt”;
}
– we need bosh
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping
}

    c2s_require_encryption = false

VirtualHost “guest.mydomain”
authentication = “anonymous”
ssl = {
key = “/etc/prosody/certs/mydomain.key”;
certificate = “/etc/prosody/certs/mydomain.crt”;
}
– we need bosh
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping
}

    c2s_require_encryption = false

After I cycle everything the virtualhost for guest.mydomain does not work.
Do I need to add anything in DNS for it?
Or is there a way on the server to check that the Virtual URL is working correctly?

Is this your actual config file or are you not showing the domain for security reasons?

should be guest.yourdomain.com i.e. guest.followed by your domain

Same thing here

VirtualHost “guest.”
authentication = “anonymous”
ssl = {
key = “/etc/prosody/certs/.key”;
certificate = “/etc/prosody/certs/.crt”;
}

not showing domain for security purposes.
Just trying to figure out if I missed something in a file or configuration.
made edit to post above to show mydoamin.