Localrecording feature

Hello!
I set up a self hosted jitsi meet. Everything works, but I can’t enable the localrecording feature. The record button is not displayed in the interface.

The setup was done according to the “Self-Hosting Guide - Debian/Ubuntu server

Next, in /etc/jitsi/meet/meet.mydomain.com-config.js:

  1. Added localrecording option to toolbarButtons array:
     toolbarButtons: [
        'camera',
        'chat',
        'closedcaptions',
        'desktop',
        'download',
        //'embedmeeting',
        'etherpad',
        'feedback',
        'filmstrip',
        'fullscreen',
        'hangup',
        'help',
        'highlight',
        'invite',
        'linktosalesforce',
        //'livestreaming',
        'microphone',
        'mute-everyone',
        'mute-video-everyone',
        'participants-pane',
        'profile',
        'raisehand',
        //'recording',
        //'security',
        'select-background',
        'settings',
        //'shareaudio',
        //'sharedvideo',
        'shortcuts',
        'stats',
        'tileview',
        'toggle-camera',
        'videoquality',
        'localrecording',
        '__end'
     ],
  1. Enabled local recording:
    // Local Recording
     localRecording: {
    // Enables local recording.
    // Additionally, 'localrecording' (all lowercase) needs to be added to
    // the `toolbarButtons`-array for the Local Recording button to show up
    // on the toolbar.
    //
         enabled: true,
    //

    // The recording format, can be one of 'ogg', 'flac' or 'wav'.
    //     format: 'flac'
           format: 'wav'
    //

    },

Interface view:

Warnings in console (don’t look like that relate to the problem):

Logger.js:154 2022-06-11T11:58:14.723Z [modules/statistics/AnalyticsAdapter.js] <Object.dispose>:  Disposing of analytics adapter.
r @ Logger.js:154

Logger.js:154 2022-06-11T11:58:16.812Z [modules/xmpp/XmppConnection.js] <Ls._maybeEnableStreamResume>:  Stream resume enabled, but WebSockets are not enabled
r @ Logger.js:154

TrackVADEmitter.js:112 [Deprecation] The ScriptProcessorNode is deprecated. Use AudioWorkletNode instead. (https://bit.ly/audio-worklet)
_initializeAudioContext @ TrackVADEmitter.js:112

Software versions:

  • jitsi-meet 2.0.7287-1
  • jitsi-meet-prosody 1.0.6155-1
  • jitsi-meet-turnserver 1.0.6155-1
  • jitsi-meet-web 1.0.6155-1
  • jitsi-meet-web-config 1.0.6155-1
  • jitsi-videobridge2 2.1-681-g3544ed05-1

Please help me set up local recording.

That function no longer exists, it was removed and replaced with one of the same name, which can also record video. It’s enabled by default and available in the Start Recording dialog.

For this new feature, does it require to be defined only on the tool bar?

toolbarButtons: [
      ...
      'recording',
      ...
 ],
localRecording: {
      disable: false,
      notifyAllParticipants: true
},
1 Like

I’ll try on a newer installation maybe mine is “old”, and some configurations may be missing.
Regards

You can see current config.js reference file at feat(local-video-recording) Allow users to record the meeting locally by robertpin · Pull Request #11338 · jitsi/jitsi-meet · GitHub

It boils down to:

    toolbarButtons: [
       // First buttons
        'recording',
      // rest of the buttons
    ],
    enableLocalRecording: true,

You can then remove all ancient traces of localRecording.

If you upgraded, you will be needing to include:

enableLocalRecording: true,

by hand.

As others pointed out, what’s in your config is the deprecated localrecording configurations.

By the way, when upgrading Jitsi using debian packages, does the upgrade process provides the upgraded configs as well? If yes, where can it be found?

No, config files are not updated (to safeguard your customizations). You can always find the most current configurations by checking in the github repo:

ah, got it. Thank you @Freddie for the confirmation.

enableLocalRecording
It was deprecated!

dpkg -l | grep jitsi
ii jitsi-meet 2.0.6826-1 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.5764-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-turnserver 1.0.5764-1 all Configures coturn to be used with Jitsi Meet
ii jitsi-meet-web 1.0.5764-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.5764-1 all Configuration for web serving of Jitsi Meet
ii jitsi-videobridge2 2.1-607-g153f7e4e-1 all WebRTC compatible Selective Forwarding Unit (SFU)

Hi, I want to enable localrecording with the above version of Jitsi meet. I tried the following:

toolbarButtons: [
      ...
      'recording',
      ...
 ],
localRecording: {
      disable: false,
      notifyAllParticipants: true
},

But still cannot see the option to start local recording.

Can someone point in the right direction, Please?

jitsi-meet 2.0.6826-1 doesn’t support local recording. You shoul install a newer version.

1 Like

what is the minimum RAM required to run “new local recording” feature and “noise suppression”.

Local recording will record up 1GB, then stop. There is no RAM requirement for noise suppression.

I want to ask if I import bundle files in libs folder (bundle “.min” files) of running project which I created on 16 GB RAM system and then replace it with another project running on 8GB RAM system with same config files then other features are running fine but noise suppression and local recording features are not showing in the more option menu. So is this issue comes because of RAM of may be other possibilities are there.

Are config.js of both systems the same?

Yes. exactly same

The backend (jicofo, jvb, etc) versions should also match

Yes they are also same.

Are you testing with the same browser?