Locally hosted video bridge: Can't create conference


#1

Hello,
I am trying to setup Jitsi backend on my machine. So far I have prosody running & nginx and I can access the Jitsi client.

I have a problem with Jitsi-videobridge and Jicofo. I build and run from sources. Here is what I get when I run JVB:

[INFO] --- exec-maven-plugin:1.4.0:exec (default-cli) @ jitsi-videobridge ---
Dec 03, 2018 4:18:07 PM net.java.sip.communicator.util.Logger info
INFO: java.net.preferIPv6Addresses=null
Dec 03, 2018 4:18:07 PM net.java.sip.communicator.util.Logger info
INFO: java.net.preferIPv4Stack=null
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/root/.m2/repository/org/slf4j/slf4j-simple/1.6.1/slf4j-simple-                    
1.6.1.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/root/.m2/repository/org/slf4j/slf4j-jdk14/1.7.7/slf4j-jdk14- 
1.7.7.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [org.slf4j.impl.SimpleLoggerFactory]
Dec 03, 2018 4:18:08 PM org.jitsi.impl.osgi.framework.BundleImpl start
SEVERE: Error starting bundle: null
java.lang.ClassNotFoundException: org.jitsi.eventadmin.Activator
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:583)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
at org.jitsi.impl.osgi.framework.BundleImpl.loadClass(BundleImpl.java:237)
at org.jitsi.impl.osgi.framework.BundleImpl.start(BundleImpl.java:305)
at org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged(FrameworkImpl.java:472)
at org.jitsi.impl.osgi.framework.startlevel.FrameworkStartLevelImpl$Command.run(FrameworkStartLevelImpl.java:137)
at org.jitsi.impl.osgi.framework.AsyncExecutor.runInThread(AsyncExecutor.java:122)
at org.jitsi.impl.osgi.framework.AsyncExecutor.access$000(AsyncExecutor.java:28)
at org.jitsi.impl.osgi.framework.AsyncExecutor$1.run(AsyncExecutor.java:231)

Similar error happens with Jicofo:
# ./jicofo.sh --host=localhost --domain=jitsi.example.com --secret=secret2 --user_domain=auth.jitsi.example --user_name=focus --user_password=secret3Jicofo 2018-12-03 15:49:50.155 SEVERE: [14] org.jitsi.impl.osgi.framework.BundleImpl.start() Error starting bundle: null
java.lang.ClassNotFoundException: org.jitsi.service.libjitsi.LibJitsiActivator
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:583)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
at org.jitsi.impl.osgi.framework.BundleImpl.loadClass(BundleImpl.java:237)
at org.jitsi.impl.osgi.framework.BundleImpl.start(BundleImpl.java:305)
at org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged(FrameworkImpl.java:472)
at org.jitsi.impl.osgi.framework.startlevel.FrameworkStartLevelImpl$Command.run(FrameworkStartLevelImpl.java:137)
at org.jitsi.impl.osgi.framework.AsyncExecutor.runInThread(AsyncExecutor.java:122)
at org.jitsi.impl.osgi.framework.AsyncExecutor.access$000(AsyncExecutor.java:28)
at org.jitsi.impl.osgi.framework.AsyncExecutor$1.run(AsyncExecutor.java:231)