Localhost graceful_shutdown.sh[119286]: curl: (7) Failed to connect to 127.0.0.1 port 3333: Connection refused

Jibri not starting ,getting below error

localhost graceful_shutdown.sh[119286]: curl: (7) Failed to connect to 127.0.0.1 port 3333: Connection refused

Share your jibri.conf and jibri log.

jibri.conf

jibri {
// A unique identifier for this Jibri
// TODO: eventually this will be required with no default
id = “”
// Whether or not Jibri should return to idle state after handling
// (successfully or unsuccessfully) a request. A value of ‘true’
// here means that a Jibri will NOT return back to the IDLE state
// and will need to be restarted in order to be used again.
single-use-mode = false
api {
http {
external-api-port = 2222
internal-api-port = 3333
}
xmpp {
// See example_xmpp_envs.conf for an example of what is expected here
environments =
}
}
recording {
recordings-directory = “/recordings”
# TODO: make this an optional param and remove the default
finalize-script = “/path/to/finalize”
}
streaming {
// A list of regex patterns for allowed RTMP URLs. The RTMP URL used
// when starting a stream must match at least one of the patterns in
// this list.
rtmp-allow-list = [
// By default, all services are allowed
“.*”
]
}
chrome {
// The flags which will be passed to chromium when launching
flags = [
“–use-fake-ui-for-media-stream”,
“–start-maximized”,
“–kiosk”,
“–enabled”,
“–disable-infobars”,
“–autoplay-policy=no-user-gesture-required”
]
}
stats {
enable-stats-d = true
}
webhook {
// A list of subscribers interested in receiving webhook events
subscribers =
}
jwt-info {
// The path to a .pem file which will be used to sign JWT tokens used in webhook
// requests. If not set, no JWT will be added to webhook requests.
# signing-key-path = “/path/to/key.pem”

// The kid to use as part of the JWT
# kid = "key-id"

// The issuer of the JWT
# issuer = "issuer"

// The audience of the JWT
# audience = "audience"

// The TTL of each generated JWT.  Can't be less than 10 minutes.
# ttl = 1 hour

}
call-status-checks {
// If all clients have their audio and video muted and if Jibri does not
// detect any data stream (audio or video) comming in, it will stop
// recording after NO_MEDIA_TIMEOUT expires.
no-media-timeout = 30 seconds

// If all clients have their audio and video muted, Jibri consideres this
// as an empty call and stops the recording after ALL_MUTED_TIMEOUT expires.
all-muted-timeout = 10 minutes

// When detecting if a call is empty, Jibri takes into consideration for how
// long the call has been empty already. If it has been empty for more than
// DEFAULT_CALL_EMPTY_TIMEOUT, it will consider it empty and stop the recording.
default-call-empty-timeout = 30 seconds

}
}

config.json

“recording_directory”: “/recordings”,
“finalize_recording_script_path”: " ",
“xmpp_server_hosts”: [
alphacodes.hopto.org
],
“xmpp_domain”: “jitsi.alphacodes.hopto.org”,
“control_login”: {
“domain”: “auth.alphacodes.hopto.org”,
“username”: “jibri”,
“password”: “In2IT#$123456”
},
“control_muc”: {
“domain”: “internal.auth.alphacodes.hopto.org”,
“room_name”: “JibriBrewery”,
“nickname”: “jibri”
}
},
“call_login”: {
“domain”: “recorder.alphacodes.hopto.org”,
“username”: “recorder”,
“password”: “In2IT#$123456”
},

jibri.log

2021-03-02 07:08:27.738 INFO: [1] org.jitsi.jibri.Main.handleCommandLineArgs() Jibri run with args [–config, /etc/jitsi/jibri/config.json]

This is incorrectly configured. Config.json has been deprecated, Jibri.conf is what you need and it needs to be properly configured. Check out this post on how to install the new Jibri - TUTORIAL - How to Install the NEW JIBRI

thanks, let me change

Changed, but same issue

● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Tue 2021-03-02 08:03:03 UTC; 1s ago
Process: 121679 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=143)
Process: 121694 ExecStop=/opt/jitsi/jibri/graceful_shutdown.sh (code=exited, status=7)
Main PID: 121679 (code=exited, status=143)

Mar 02 08:03:03 localhost graceful_shutdown.sh[121696]: Dload Upload Total Spent Left Speed
Mar 02 08:03:03 localhost graceful_shutdown.sh[121696]: [158B blob data]
Mar 02 08:03:03 localhost graceful_shutdown.sh[121696]: curl: (7) Failed to connect to 127.0.0.1 port 3333: Connection refused
Mar 02 08:03:03 localhost systemd[1]: jibri.service: Control process exited, code=exited, status=7/NOTRUNNING
Mar 02 08:03:03 localhost systemd[1]: jibri.service: Main process exited, code=exited, status=143/n/a
Mar 02 08:03:03 localhost systemd[1]: jibri.service: Failed with result ‘exit-code’.
Mar 02 08:03:03 localhost systemd[1]: Stopped Jibri Process.
Mar 02 08:03:03 localhost systemd[1]: jibri.service: Start request repeated too quickly.
Mar 02 08:03:03 localhost systemd[1]: jibri.service: Failed with result ‘exit-code’.
Mar 02 08:03:03 localhost systemd[1]: Failed to start Jibri Process.

root@localhost:/var/log/jitsi/jibri# cat log.0.txt
2021-03-02 08:03:02.622 INFO: [1] org.jitsi.jibri.Main.handleCommandLineArgs() Jibri run with args [–config, /etc/jitsi/jibri/config.json]
2021-03-02 08:03:02.710 INFO: [1] org.jitsi.jibri.Main.setupLegacyConfig() Checking legacy config file /etc/jitsi/jibri/config.json
2021-03-02 08:03:02.711 INFO: [1] org.jitsi.jibri.Main.setupLegacyConfig() Legacy config file /etc/jitsi/jibri/config.json doesn’t exist

help me out please

now getting this

Mar 02 10:10:45 localhost launch.sh[123313]: Exception in thread “main” com.fasterxml.jackson.core.JsonParseException: Unrecognized token ‘jibri’: was expecting (‘true’, ‘false’ or ‘null’)

is there anyone to help me out?

Go through above post and share all relevant details.

@Prashanth i have go through with this already, everything seems correct, I’m surprise why this error occur…

localhost launch.sh[123313]: Exception in thread “main” com.fasterxml.jackson.core.JsonParseException: Unrecognized token ‘jibri’: was expecting (‘true’, ‘false’ or ‘null’)

@shanu you wouldn’t have gone through that post as it was created yesterday. If you have, it says what information you need to provide, like your server details, jibri version, jibri.conf, jibri logs.

Those all will help others in understanding the issue more and help.

Check these things once: Jibri not working - #11 by Prashanth

jibri.conf

jibri {
// A unique identifier for this Jibri
// TODO: eventually this will be required with no default
id = “”
// Whether or not Jibri should return to idle state after handling
// (successfully or unsuccessfully) a request. A value of ‘true’
// here means that a Jibri will NOT return back to the IDLE state
// and will need to be restarted in order to be used again.
single-use-mode = false
api {
http {
external-api-port = 2222
internal-api-port = 3333
}
xmpp {
// See example_xmpp_envs.conf for an example of what is expected here
environments = [
{
name = “prod environment”
xmpp-server-hosts = [“172.16.10.112”]
xmpp-domain = “alphacodes.hopto.org

            control-muc {
                domain = "internal.auth.alphacodes.hopto.org"
                room-name = "JibriBrewery"
                nickname = "jibri-nickname"
            }

            control-login {
                domain = "auth.alphacodes.hopto.org"
                username = "jibri"
                password = "In2IT#$123456"
            }

            call-login {
                domain = "recorder.alphacodes.hopto.org"
                username = "recorder"
                password = "In2IT#$123456"
            }

            strip-from-room-domain = "conference."
            usage-timeout = 0
            trust-all-xmpp-certs = true
        }]
}

}
recording {
recordings-directory = “/srv/recordings”
# TODO: make this an optional param and remove the default
finalize-script = “/opt/jitsi/jibri/finalize_recording.sh”
}
streaming {
// A list of regex patterns for allowed RTMP URLs. The RTMP URL used
// when starting a stream must match at least one of the patterns in
// this list.
rtmp-allow-list = [
// By default, all services are allowed
“.*”
]
}
chrome {
// The flags which will be passed to chromium when launching
flags = [
“–use-fake-ui-for-media-stream”,
“–start-maximized”,
“–kiosk”,
“–enabled”,
“–disable-infobars”,
“–autoplay-policy=no-user-gesture-required”
]
}
stats {
enable-stats-d = true
}
webhook {
// A list of subscribers interested in receiving webhook events
subscribers =
}
jwt-info {
// The path to a .pem file which will be used to sign JWT tokens used in webhook
// requests. If not set, no JWT will be added to webhook requests.
# signing-key-path = “/path/to/key.pem”

// The kid to use as part of the JWT
# kid = "key-id"

// The issuer of the JWT
# issuer = "issuer"

// The audience of the JWT
# audience = "audience"

// The TTL of each generated JWT.  Can't be less than 10 minutes.
# ttl = 1 hour

}
call-status-checks {
// If all clients have their audio and video muted and if Jibri does not
// detect any data stream (audio or video) comming in, it will stop
// recording after NO_MEDIA_TIMEOUT expires.
no-media-timeout = 30 seconds

// If all clients have their audio and video muted, Jibri consideres this
// as an empty call and stops the recording after ALL_MUTED_TIMEOUT expires.
all-muted-timeout = 10 minutes

// When detecting if a call is empty, Jibri takes into consideration for how
// long the call has been empty already. If it has been empty for more than
// DEFAULT_CALL_EMPTY_TIMEOUT, it will consider it empty and stop the recording.
default-call-empty-timeout = 30 seconds

}
}

root@localhost:/var/log/jitsi/jibri# cat log.0.txt
2021-03-03 04:49:54.600 INFO: [1] org.jitsi.jibri.Main.handleCommandLineArgs() Jibri run with args [–config, /etc/jitsi/jibri/jibri.conf]
2021-03-03 04:49:54.721 INFO: [1] org.jitsi.jibri.Main.setupLegacyConfig() Checking legacy config file /etc/jitsi/jibri/jibri.conf

root@localhost:/var/log/jitsi/jibri# systemctl status jibri
● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Wed 2021-03-03 04:49:55 UTC; 25min ago
Process: 128881 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=1/FAILURE)
Main PID: 128881 (code=exited, status=1/FAILURE)

Mar 03 04:49:55 localhost systemd[1]: jibri.service: Scheduled restart job, restart counter is at 2.
Mar 03 04:49:55 localhost systemd[1]: Stopped Jibri Process.
Mar 03 04:49:55 localhost systemd[1]: jibri.service: Start request repeated too quickly.
Mar 03 04:49:55 localhost systemd[1]: jibri.service: Failed with result ‘exit-code’.
Mar 03 04:49:55 localhost systemd[1]: Failed to start Jibri Process.

Due to jibri not running, jitsi page also not opening, please suggest any other information

jibri has nothing to do with jitsi page opening. check if nginx service is running(systemctl status nginx). If not start it and then page should be accessible.

Try with hostname instead of IP.

nginx running and changed Ip with hostname

getting jitsi blank page.

You likely skipped a punctuation in your config.js. Go back and look at whatever changes you made in your config.js, that’s most likely where the problem is.

thanks, there was a problem with config.js file.

please suggest me should i setup jibri on same server or on dedicated server & what will be the minimum RAM & CPU require

You can do either, but for best performance, in your case, I’d recommend hosting Jibri on a separate server. If you choose to go that route, you’ll need at least 4 CPUs and 8GB of RAM for trouble-free recording.