Local recording sound echo

Hello Everyone I have issue with local recording new feature and when I reviewing the the record I found out the participate voice is echoing, is there any configuration to resolve this issue.

thank you.

Whose voice is echoing, the local participant’s ? What browser are you using?

I was facing the voice echoing for local participant’s but I figure out the issue is when I choose the the tab which I need to record I’m choosing the option “Share Tab Audio” when I removed the tick it’s working Properly.

Thank you @saghul for your effort.

You are supposed to share that, otherwise there will be no remote participants audio.

What Chrome version and operating system do you have?


I mean when you start local recording and choose the specific tab to record you should remove the (Share Tab Audio) mark to not record the tab audio and the participant voice it will be duplicate.

as it showing in the attached pic

If you don’t mark that box then the recording won’t have the remote audio.

When i do uncheck that choice it’s working properly all the voices is clear main and participate.

@robertpin Am I missing something here? That shouldn’t work, right?

It should. We add the remote tracks directly to the recording. If you don’t share audio you’ll not get reaction sounds/ share video sound.
What doesn’t make sense is the echo: local audio is not part of the tab audio (we don’t play back your audio in your speakers)

Yeah, indeed.

I didn’t remember we wound up adding all remote tracks to the mixer, when I guess we could even stop requesting audio sharing, since it’s just for sound effects?