Local Recording not work [SOLVED]

Greetings to all!
Debian 10.6
jitsi-meet/stable,now 2.0.5142-1
jibri/stable,now 8.0-61-g99288dc-1

After configuring according to the instructions https ://community.jitsi.org/t/how-to-to-setup-integrated-jitsi-and-jibri-for-dummies-my-comprehensive-tutorial-for-the-beginner/35718, the record worked, but today suddenly stopped.
log.0.txt:

2020-11-12 09:29:03.830 INFO: [7910] org.jitsi.jibri.api.xmpp.XmppApi.handleJibriIq() Received JibriIq from environment [MucClient id=vks.videodomain.ru hostname=vks.videodomain.ru]
2020-11-12 09:29:03.830 INFO: [7910] org.jitsi.jibri.api.xmpp.XmppApi.handleStartJibriIq() Received start request, starting service
2020-11-12 09:29:03.836 INFO: [7910] org.jitsi.jibri.api.xmpp.XmppApi.handleStartService() Parsed call url info: CallUrlInfo(baseUrl=https://vks.videodomain.ru, callName=vks12345, urlParams=)
2020-11-12 09:29:03.836 INFO: [7910] org.jitsi.jibri.JibriManager.startFileRecording() Starting a file recording with params: FileRecordingRequestParams(callParams=CallParams(callUrlInfo=CallUrlInfo(baseUrl=https://vks.videodomain.ru, callName=vks12345, urlParams=)), sessionId=atovrfkecxvbxxfv, callLoginParams=XmppCredentials(domain=recorder.vks.videodomain.ru, username=recorder, password=Pa$$woRd))
2020-11-12 09:29:04.270 INFO: [7910] org.openqa.selenium.remote.ProtocolHandshake.createSession() Detected dialect: OSS
2020-11-12 09:29:04.273 FINE: [7910] org.jitsi.jibri.capture.ffmpeg.FfmpegCapturer.() Detected os as OS: LINUX
2020-11-12 09:29:04.274 INFO: [7910] org.jitsi.jibri.service.impl.FileRecordingJibriService.() Writing recording to /var/recordings/atovrfkecxvbxxfv, finalize script path /opt/jitsi/jibri/postrecord.sh
2020-11-12 09:29:04.274 FINE: [7910] org.jitsi.jibri.statsd.JibriStatsDClient.incrementCounter() Incrementing statsd counter: start:recording
2020-11-12 09:29:04.274 INFO: [7910] org.jitsi.jibri.status.JibriStatusManager.log() Busy status has changed: IDLE -> BUSY
2020-11-12 09:29:04.274 FINE: [7910] org.jitsi.jibri.webhooks.v1.WebhookClient.invokeSuspend() Updating 0 subscribers of status
2020-11-12 09:29:04.274 INFO: [7910] org.jitsi.jibri.api.xmpp.XmppApi.updatePresence() Jibri reports its status is now JibriStatus(busyStatus=BUSY, health=OverallHealth(healthStatus=HEALTHY, details={})), publishing presence to connections
2020-11-12 09:29:04.275 INFO: [7910] org.jitsi.jibri.api.xmpp.XmppApi.handleStartJibriIq() Sending ‘pending’ response to start IQ
2020-11-12 09:29:05.334 FINE: [7920] org.jitsi.jibri.selenium.pageobjects.CallPage.visit() Visiting url https://vks.videodomain.ru/vks12345#config.iAmRecorder=true&config.externalConnectUrl=null&config.startWithAudioMuted=true&config.startWithVideoMuted=true&interfaceConfig.APP_NAME=“Jibri”&config.analytics.disabled=true&config.p2p.enabled=false&config.prejoinPageEnabled=false&config.requireDisplayName=false
2020-11-12 09:29:05.859 FINE: [7920] org.jitsi.jibri.selenium.pageobjects.CallPage.apply() Not joined yet: Cannot read property ‘isJoined’ of undefined
2020-11-12 09:29:06.409 FINE: [7920] org.jitsi.jibri.selenium.pageobjects.CallPage.apply() Not joined yet: Cannot read property ‘isJoined’ of undefined
2020-11-12 09:29:13.132 FINE: [18] org.jitsi.jibri.webhooks.v1.WebhookClient.invokeSuspend() Updating 0 subscribers of status
2020-11-12 09:29:36.305 SEVERE: [7920] org.jitsi.jibri.selenium.pageobjects.CallPage.visit() Timed out waiting for call page to load
2020-11-12 09:29:36.305 INFO: [7920] org.jitsi.jibri.selenium.JibriSelenium.onSeleniumStateChange() Transitioning from state Starting up to Error: FailedToJoinCall SESSION Failed to join the call
2020-11-12 09:29:36.305 INFO: [7920] org.jitsi.jibri.service.impl.FileRecordingJibriService.onServiceStateChange() File recording service transitioning from state Starting up to Error: FailedToJoinCall SESSION Failed to join the call
2020-11-12 09:29:36.305 INFO: [7920] org.jitsi.jibri.api.xmpp.XmppApi.invoke() Current service had an error Error: FailedToJoinCall SESSION Failed to join the call, sending error iq
2020-11-12 09:29:36.305 FINE: [7920] org.jitsi.jibri.statsd.JibriStatsDClient.incrementCounter() Incrementing statsd counter: stop:recording
2020-11-12 09:29:36.305 INFO: [7920] org.jitsi.jibri.JibriManager.stopService() Stopping the current service
2020-11-12 09:29:36.306 INFO: [7920] org.jitsi.jibri.service.impl.FileRecordingJibriService.stop() Stopping capturer
2020-11-12 09:29:36.306 INFO: [7920] org.jitsi.jibri.util.JibriSubprocess.ffmpeg.stop() Stopping ffmpeg process
2020-11-12 09:29:36.306 INFO: [7920] org.jitsi.jibri.util.JibriSubprocess.ffmpeg.stop() ffmpeg exited with value null
2020-11-12 09:29:36.306 INFO: [7920] org.jitsi.jibri.service.impl.FileRecordingJibriService.stop() Quitting selenium
2020-11-12 09:29:36.316 INFO: [7920] org.jitsi.jibri.service.impl.FileRecordingJibriService.stop() Participants in this recording:
2020-11-12 09:29:36.320 INFO: [7920] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Leaving call and quitting browser
2020-11-12 09:29:36.320 INFO: [7920] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Recurring call status checks cancelled
2020-11-12 09:29:36.324 INFO: [7920] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Got 18 log entries for type browser
2020-11-12 09:29:36.350 INFO: [7920] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Got 1101 log entries for type driver
2020-11-12 09:29:36.455 INFO: [7920] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Got 0 log entries for type client
2020-11-12 09:29:36.455 INFO: [7920] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Leaving web call
2020-11-12 09:29:41.493 SEVERE: [7920] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Error trying to leave the call: org.openqa.selenium.JavascriptException: javascript error: The timeout for the confirmation about leaving the room expired.
(Session info: chrome=86.0.4240.183)
(Driver info: chromedriver=86.0.4240.22 (398b0743353ff36fb1b82468f63a3a93b4e2e89e-refs/branch-heads/4240@{#378}),platform=Linux 4.19.0-12-amd64 x86_64) (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 0 milliseconds
Build info: version: ‘unknown’, revision: ‘unknown’, time: ‘unknown’
System info: host: ‘Unknown’, ip: ‘Unknown’, os.name: ‘Linux’, os.arch: ‘amd64’, os.version: ‘4.19.0-12-amd64’, java.version: ‘1.8.0_272’
Driver info: org.openqa.selenium.chrome.ChromeDriver
Capabilities {acceptInsecureCerts: false, acceptSslCerts: false, applicationCacheEnabled: false, browserConnectionEnabled: false, browserName: chrome, chrome: {chromedriverVersion: 86.0.4240.22 (398b0743353ff…, userDataDir: /tmp/.com.google.Chrome.96fWUF}, cssSelectorsEnabled: true, databaseEnabled: false, goog:chromeOptions: {debuggerAddress: localhost:44707}, handlesAlerts: true, hasTouchScreen: false, javascriptEnabled: true, locationContextEnabled: true, mobileEmulationEnabled: false, nativeEvents: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: LINUX, platformName: LINUX, proxy: Proxy(), rotatable: false, setWindowRect: true, strictFileInteractability: false, takesHeapSnapshot: true, takesScreenshot: true, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}, unexpectedAlertBehaviour: ignore, unhandledPromptBehavior: ignore, version: 86.0.4240.183, webStorageEnabled: true, webauthn:virtualAuthenticators: true}

I thank

You’re saying Jibri was working fine, but suddenly stopped working? Did anything change in your configuration?

No has not changed. I decided to conduct an experiment when the conference was held in which the recording did not work I created another conference and the recording worked in it. This morning, I re-created the conference using the same link in which the recording did not work yesterday, and the recording works. I don’t know what it’s about, I’ll keep watching. If you need to provide some logistic files, I will do it. I’m sorry if I’m not writing right because I’m doing it through a translator.

No problem at all, I fully understand what you’re saying.

Since you’ve been unable to recreate the problem, I suggest that the next time you run into an issue recording, just restart the service. Like any other software/application, there can be occasional dysfunction (sometimes, due to something as simple as caching), so restarting helps to flush out anything that could be causing the issue. To restart jibri:

sudo systemctl restart jibri

Personally, I prefer to restart all services, if possible, so I use:

sudo systemctl restart jitsi-videobridge2 prosody jicofo jibri

Of course, if you already have an ongoing meeting, it may not be feasible to restart all services, so restarting jibri alone might be your only option.

Thank you!
Right, I had a conference in which there were many participants and therefore I did not dare to restart. In this case, I will create a task to reboot the server every night. And how did I understand if there is such a problem with the conference already underway enough to restart jibri so as not to cause a breakdown of the connection?

You should be able to restart the Jibri service without disrupting the actual meeting. So if you’ve started a meeting and you’re having problems recording, then just restart Jibri. Maybe it’s even better to start recording before people actually enter the meeting room, if possible. That way, if there’s a problem, you would know before the meeting starts and be able to restart all services.

Thank you, I will try :slight_smile: