Lobby With JWT

Anyone have any documents or tips on enabling the Lobby feature with JWT auth enabled?
The normal secure domain implementation doesn’t work, the host/creator never see the option to enable Lobby. If i put the muc_lobby_rooms in the main VirtualHost config it will present the option for the moderator however when a guest joins there is never a notification in the room that someone is waiting. Without JWT (internal_auth) everything works as expected in the secure domain instructions of enabling Lobby.
I can’t really find anything in any of the error logs indicating where the problem is.

I have the same problem.

I’ve tried to configure the prosody in several ways, both the official and the community ones, nothing worked. Has anyone done it?

The fact is that I must use a token (for both moderators and visitors) and at the same time I have to be able to activate the lobby, not to mention the other settings I need, such as a lobby bypass for moderating participants (controlled by jwt).

Some errors when I try to enable Lobby:

Lobby toggle button
image

Prosody logs

Note the stanzarouter warn, its do not recognize the JID and, the JID have a concatenated same id 2 times.

The only way we were able to get it to work was to remove the guest domain and allow empty tokens in the primary virtualhost. It still doesn’t behave correctly with JWT and the iFrame API. I have tried the tokens with the moderator plugin but you still get prompted to enter the password or ask the host to let you in. Now if you do either of those and you join as a moderator, it will tell you you’re a moderator but not give you moderator permissions. Hopefully someone else has figured this out, i’m sure it’s just about using the correct combination the hosts and components with lobby.