Lobby stopped working after configuring tokens

I set up the lobby feature a while ago and it was working… then I set up token auth and lobby stopped working. Meanwhile, I upgraded all of the components to the latest unstable debs.

Trying to track down what went wrong with the lobby config, I backtracked and tried disabling token auth, but still no lobby.

Here’s my prosody site configs:

VirtualHost "beach.mydomain.us"
        -- enabled = false -- Remove this line to enable this host
        authentication = "internal_plain"

        -- authentication = "token";
        -- app_id="xxx";
        -- app_secret="xxx";
        -- allow_empty_token = true;

        ssl = {
                key = "/etc/prosody/certs/beach.mydomain.us.key";
                certificate = "/etc/prosody/certs/beach.mydomain.us.crt";
        }
        speakerstats_component = "speakerstats.beach.mydomain.us"
        conference_duration_component = "conferenceduration.beach.mydomain.us"
        -- we need bosh
        modules_enabled = {
            "bosh";
            "pubsub";
            "ping"; -- Enable mod_ping
            "speakerstats";
            "turncredentials";
            "conference_duration";
            -- "presence_identity"; -- for token auth
            "muc_size";
            "muc_status";
        }
        c2s_require_encryption = false
VirtualHost "guest.beach.mydomain.us"
    -- enabled = false
    authentication = "anonymous"
    speakerstats_component = "speakerstats.beach.mydomain.us" -- dmk
    conference_duration_component = "conferenceduration.beach.mydomain.us" -- dmk
    modules_enabled = { -- dmk
        --"bosh";
        --"pubsub";
        --"ping"; -- Enable mod_ping
        "speakerstats";
        --"turncredentials";
        "conference_duration"; -- this is required for timer to work
        "muc_lobby_rooms";
    }
    c2s_require_encryption = false
    lobby_muc = "lobby.beach.mydomain.us"
    main_muc = "conference.beach.mydomain.us"
Component "lobby.beach.mydomain.us" "muc"
    storage = "memory";
    restrict_room_creation = true
    muc_room_locking = false
    muc_room_default_public_jids = true

There are more sections, but not sure if they are relevant to lobbies, and wanted to keep from cluttering the message. I can post the whole file if that helps.

Thanks!

My bad… looks like lobby was working with this config… I just needed to enable it in the room.
Is there a setting to turn lobby on in new rooms by default?

Hm… turned token auth back on, and lobby option is gone again.

Ok, I was able to get the lobby working by disabling the guest virtualhost and moving lobby config into main virtualhost section.

Still have several issues with token verification though… I’ll post that in a new thread.