Lobby not working after upgrading to latest Jitsi version (2.0.5390)

Hello everybody.

I’ve configured the Jitsi lobby via secure domain and it worked fine until I upgraded Jitsi yesterday to the latest version 2.0.5390. I already checked my cfg.lua file it is still there and not changed. I also could not see any other relevant changed file.

The issue is that since this update the lobby is not even available. So in a room there is no lobby feature available.

Is there any change in this version that I have to do first to get the lobby back?

I’ve already checked all the logs but there is nothing suspicious to me. Honestly I also dont know “what” I should see there in a good case.

I’ve noticed in the changelog of this version this “fix: Avoids storing lobby room instance in the main room object”. But I dont know if and what that might change to my cfg.lua or whatever else

Thanks!

Can you share your lua file?

Of course. here it is

plugin_paths = { “/usr/share/jitsi-meet/prosody-plugins/” }

– domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = “meet.amadee-cloud.de”;

turncredentials_secret = “XXXXX”;

turncredentials = {
{ type = “stun”, host = “meet.amadee-cloud.de”, port = “4446” },
{ type = “turn”, host = “meet.amadee-cloud.de”, port = “4446”, transport = “udp” },
{ type = “turns”, host = “meet.amadee-cloud.de”, port = “443”, transport = “tcp” }
};

cross_domain_bosh = false;
consider_bosh_secure = true;

VirtualHost “meet.amadee-cloud.de
– enabled = false – Remove this line to enable this host
authentication = “internal_plain”
ssl = {
key = “/etc/prosody/certs/meet.amadee-cloud.de.key”;
certificate = “/etc/prosody/certs/meet.amadee-cloud.de.crt”;
}
speakerstats_component = “speakerstats.meet.amadee-cloud.de
conference_duration_component = “conferenceduration.meet.amadee-cloud.de
– we need bosh
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping
“speakerstats”;
“turncredentials”;
“conference_duration”;
}
c2s_require_encryption = false

VirtualHost “guest.meet.amadee-cloud.de
authentication = “anonymous”
c2s_require_encryption = false
modules_enabled = {
“muc_lobby_rooms”;
}
lobby_muc = “lobby.meet.amadee-cloud.de
main_muc = “conference.meet.amadee-cloud.de

Component “lobby.meet.amadee-cloud.de” “muc”
storage = “memory”
restrict_room_creation = true
muc_room_locking = false
muc_room_default_public_jids = true

Component “conference.meet.amadee-cloud.de” “muc”
storage = “memory”
modules_enabled = {
“muc_meeting_id”;
“muc_domain_mapper”;
– “token_verification”;
}
admins = { “focus@auth.meet.amadee-cloud.de” }
muc_room_locking = false
muc_room_default_public_jids = true

– internal muc component
Component “internal.auth.meet.amadee-cloud.de” “muc”
storage = “memory”
modules_enabled = {
“ping”;
}
admins = { “focus@auth.meet.amadee-cloud.de”, “jvb@auth.meet.amadee-cloud.de” }
muc_room_locking = false
muc_room_default_public_jids = true

VirtualHost “auth.meet.amadee-cloud.de
ssl = {
key = “/etc/prosody/certs/auth.meet.amadee-cloud.de.key”;
certificate = “/etc/prosody/certs/auth.meet.amadee-cloud.de.crt”;
}
authentication = “internal_plain”

Component “focus.meet.amadee-cloud.de
component_secret = “XXXXX”

Component “speakerstats.meet.amadee-cloud.de” “speakerstats_component”
muc_component = “conference.meet.amadee-cloud.de

Component “conferenceduration.meet.amadee-cloud.de” “conference_duration_component”
muc_component = “conference.meet.amadee-cloud.de

I had this problem today too.
i have fix this transfer lobby block to main VirtualHost section.

Try this config:

plugin_paths = { “/usr/share/jitsi-meet/prosody-plugins/” }

– domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = “meet.amadee-cloud.de”;

turncredentials_secret = “XXXXX”;

turncredentials = {
{ type = “stun”, host = “meet.amadee-cloud.de”, port = “4446” },
{ type = “turn”, host = “meet.amadee-cloud.de”, port = “4446”, transport = “udp” },
{ type = “turns”, host = “meet.amadee-cloud.de”, port = “443”, transport = “tcp” }
};

cross_domain_bosh = false;
consider_bosh_secure = true;

VirtualHost “meet.amadee-cloud.de”
– enabled = false – Remove this line to enable this host
authentication = “internal_plain”
ssl = {
key = “/etc/prosody/certs/meet.amadee-cloud.de.key”;
certificate = “/etc/prosody/certs/meet.amadee-cloud.de.crt”;
}
speakerstats_component = “speakerstats.meet.amadee-cloud.de”
conference_duration_component = “conferenceduration.meet.amadee-cloud.de”
– we need bosh
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping
“speakerstats”;
“turncredentials”;
“conference_duration”;
“muc_lobby_rooms”;
}
c2s_require_encryption = false
lobby_muc = “lobby.meet.amadee-cloud.de”
main_muc = “conference.meet.amadee-cloud.de”

Component “lobby.meet.amadee-cloud.de” “muc”
storage = “memory”
restrict_room_creation = true
muc_room_locking = false
muc_room_default_public_jids = true

VirtualHost “guest.meet.amadee-cloud.de”
authentication = “anonymous”
c2s_require_encryption = false
modules_enabled = {
}

Component “conference.meet.amadee-cloud.de” “muc”
storage = “memory”
modules_enabled = {
“muc_meeting_id”;
“muc_domain_mapper”;
– “token_verification”;
}
admins = { “focus@auth.meet.amadee-cloud.de” }
muc_room_locking = false
muc_room_default_public_jids = true

– internal muc component
Component “internal.auth.meet.amadee-cloud.de” “muc”
storage = “memory”
modules_enabled = {
“ping”;
}
admins = { “focus@auth.meet.amadee-cloud.de”, “jvb@auth.meet.amadee-cloud.de” }
muc_room_locking = false
muc_room_default_public_jids = true

VirtualHost “auth.meet.amadee-cloud.de”
ssl = {
key = “/etc/prosody/certs/auth.meet.amadee-cloud.de.key”;
certificate = “/etc/prosody/certs/auth.meet.amadee-cloud.de.crt”;
}
authentication = “internal_plain”

Component “focus.meet.amadee-cloud.de”
component_secret = “XXXXX”

Component “speakerstats.meet.amadee-cloud.de” “speakerstats_component”
muc_component = “conference.meet.amadee-cloud.de”

Component “conferenceduration.meet.amadee-cloud.de” “conference_duration_component”
muc_component = “conference.meet.amadee-cloud.de”
1 Like

In this block:

key = “/etc/prosody/certs/meet.amadee-cloud.de.key”;
certificate = “/etc/prosody/certs/meet.amadee-cloud.de.crt”;
}
speakerstats_component = “[speakerstats.meet.amadee-cloud.de](http://speakerstats.meet.amadee-cloud.de/)”
conference_duration_component = “[conferenceduration.meet.amadee-cloud.de](http://conferenceduration.meet.amadee-cloud.de/)”
– we need bosh
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping
“speakerstats”;
“turncredentials”;
“conference_duration”;
}
c2s_require_encryption = false

Remove that last line:

c2s_require_encryption = false

Thanks @Freddie. I tried it but with no success. After the change and restarting all the services I can still not see the lobby.

What do your logs show? Share your prosody and Jicofo logs.

@Freddie files are attached

prosody.log (14.3 KB)

jicofo.log (56.6 KB)

What version of Prosody are you running?

@joelynnturner thank you very much, that one did the trick!!

Do you know “why” this is working? According to the secure domain lobby documentation here your solution would be wrong configured? So i mean this Secure Domain setup · Jitsi Meet Handbook and this [How to] How do I use the new Lobby Feature? - #10 by alveox

@Freddie I use 11.7. I could solve the problem by the help of @joelynnturner. Thanks

O there is a note in the secure domain doc that is not needed anymore, I’m deleting it.