Lobby after administrator disconnected

We have the problem with a situation when administrator created lobby and invite some people. One administator on session only!. After that administrator had a internet problem and he disconnected from session. When he connect again he couldn’t because he saw invite to lobby himself. (he can’t be administrator again).

Our version:
jicofo - Version: 1.0-612
jitsi-videobridge - Version: 2.1-273-g072dd44b
jitsi-meet - Version: 1.0.4289

workaround for this is to set the meeting password too. that’s how I’m avoiding this situation.
@saghul @damencho Is there any better way to tackle this situation?

Hi, thanks for the provided workaroud but it does not fully solve our problem.

When moderator (lobby owner = the user who turned on lobby but got disconnected) joins the session using password he DOES NOT recieve room access notifications from other users.
This does not work even after he logs in with our AD credentials again using: SETTINGS -> PROFILE -> LOG IN.

If there is a way to turn on notifications for this re-connected moderator, this workaround will solve our problem.

Thanks in advance for any help.

@RomanWah yeah, this is an issue that I don’t think there’s any simple workaround for yet (at least, not to the best of my knowledge). The only way I’ve been able to get around this is simply to restart services; this kicks everyone out of the meeting for a quick few seconds and brings them back in. Then the moderator gets notified about people knocking again and can let them in.

There is a way but a bit complicated:

  • activate the JWT authentication but allow also to connect without a token too
    allow_empty_token = true

  • enable token_affiliation too

  • set a meeting password then activate the lobby mode

  • The moderator can reconnect and regain the moderator right if she uses a token

I have found that this problem is described here:

and is still waiting for bugfixing.