Loads of background noise and feedback with self-hosted Jitsi Meet

Hi! We’ve set up a Jitsi Meet server for an event but the noise cancellation doesn’t seem to be working well. Even when it’s just two users in the same meeting, there is a lot of feedback between participants, especially those that have external speakers. Is there any way that noise cancellation can be tweaked to be more aggressive? I don’t have any extra settings enabled. Which ones would you recommend to solve this issue? We haven’t encountered these problems with Zoom or other platforms.

Thank you!