Loadbalancer in front of jitis-meet


#1

I’m trying to configure jitis-meet to have a loadbalancer in front of it where all of the request are going to come from. the loadbalancer is setup internet facing and the jitis meet instance is set up in a internal private network. Currently internally jitsi is working, but I need to know what changes if any I should make to the nginx configuration file to allow external access to jitsi using the loadbalancer.


#2

What changes do you mean for nginx?

Is your jvb on the same machine as jitsi-meet? If yes, and the public address will be your load balancer you need to configure the public ip address for jvb, check quick-install doc advanced, for nat and ports.

How are you load balancing? You need to make sure requests for the same room name goes to the same jitsi-meet instance.


#3

currently I only have one machine with all the services installed in it for testing purposes. I want to use a aws lb in front of the machine which is located in our internal network. I wasn’t sure about the advance part of the install, but thanks for pointing me in that direction. I will try that configuration.

I wasn’t sure what the best way to loadbalance jitsi meet since your right, how would I make sure the request for the same room goes to the same jitis meet instance, any feedback in this area /architecture would we appreciate.


#4

Http requests you can mach on a parameter room, all bosh rquests or any request that needs this matching will have the parameter. Others like serving the index can be random.


#5

I tried setting up jitsi behind a loadbalancer this morning with the changes you suggested about adding the public an private IPs. I still can’t get my webpage to resolve with the loadbalancer. I get a grey page displayed, and when I inspect the element is see the following error “InterfaceConfig is not defined”

Not sure if this mean some of the scripts are not being loaded
image

Do I need to have any ports enabled in the loadbalancer side ?


#6

What webserver do you use to serve jitsi-meet? It seems it doesn’t have ssi turned on.


#7

I’m using nginx on ubuntu 16.I check that the ssi was configured in the config file of the sites-enabled directory. Also when i load jitsi from the IP address instead of going through the loadbalancer it eh jitsi page loads. with all the required files. It fails when I try to go though the aws loadbalancer. I just get a gray screen.


#8

Isn’t the loadbalancer you use just open http or https connection to the original host, not sure what is the difference so nginx will have ssi off … Can it be that it access it by http://ip.address where you test it with domain name?