Livestream YouTube Audio Crackling like jack contact sound, solutions?

I can confirm that adding -af aresample=async=1 to ffmpeg command solved the problem. Now there is no cracking sound in live streaming. Thanks @bbaldino for this solution!

Tiny suggestion: It would be so easy to do tests if we get ffmpeg parameters from a config file. I wish to see this in upcoming releases =)


I must apologize since I just realized that this thread belongs to “instal and config” and “jibri”, so its solution doesn’t solve my problem, being that I connect to jitsi using the app for android and the browsers in my notebook.

Should I create a new thread with my problem in another part of the forum, or will the solution found here have any effect on solving the problem in general?

Of course, thank you very much for your answer.
I don’t speak English, so I use a translator.
I’m sorry if something is not understood.

Hi @rjgout, try again. The quotes in the post are now correct… Sorry for the inconvenience.

Yes! It works, Thanks a bunch! I see you added a $.

No, I used 'preformatted text' in stead of


so the quotes are now correct :wink:

Nice it works for you now :+1:

The problem was solved, since Saturday June 13 that no noises appear in my transmission.
Thank you so much to those who worked on it.

1 Like

This has been solved in this commit!

Thanks to all!

Finally had time to test, and as everyone is saying, it is fixed! Even combines with using pulse! Very amazing. Huge thanks to everyone!

Will use the wrapper script for now for both noise and pulse support, and hope pulse also makes into mainline, as it is much better when you do not need non AWS kernel when on AWS :smiley: And also will have to wait for debian package to be built.

In any case, super greatfull!

When will this commit be put in the stable release?

We are having the same issue, but we can’t recompile jibri, how can we get those changes? any idea on updating a production jibri without losing settings? @damencho @cad0p

Read through thread, you do not need to compile anything, just a wrapper script for ffmpeg.

@damencho @bbaldino Have you made a new debian jibri package for this for the jitsi-meet debian/ubuntu repository yet?

I ask because I have not received an update or upgrade notification in ubuntu and I’m still experiencing crackling on all my videos.

thank you

i think you are wrong friend

Hi @oscarb,
I’m a little unclear as to which file, the location /usr/local/bin/ffmpeg Is a folder not a file. And has contents is there something I missed? Thank you.

/usr/local/bin/ffmpeg should not be a folder (directory). The script /usr/local/bin/ffmpeg is a “wrapper” around /usr/bin/ffmpeg. The Jibri-user has /usr/local/bin in it’s PATH-setting first so when running ffmpeg the script /usr/local/bin/ffmpeg is run, which calls the real ffmpeg binary (/usr/bin/ffmpeg).

For completion the content of the script /usr/local/bin/ffmpeg:

exec /usr/bin/ffmpeg $(echo "$@" | sed 's/44100/44100 -af aresample=async=1/')

Make it executable with:

chmod +x /usr/local/bin/ffmpeg

But there is already a package (see comment #82) in which the settings are compiled, so /usr/local/bin/ffmpeg is then no longer needed.



Thank you @oscarb I appreciate the time you took to reply to my question and clarifying. :slight_smile:

I used this to update jibri to the latest unstable, where it seems to be fixed:

First install the Jitsi repository key onto your system:

wget -qO - | sudo apt-key add -

Create a sources.list.d file with the repository:

sudo sh -c "echo 'deb unstable/' > /etc/apt/sources.list.d/jitsi-unstable.list"

Update your package list:

sudo apt-get -y update

Install the latest jibri

sudo apt-get install jibri
1 Like

@gbelvedere worked perfectly, Thank you.