Livestream YouTube Audio Crackling like jack contact sound, solutions?

Not any crackling sounds promising! I’m away this weekend but soon give it a try :grinning::+1:

I did a short implementation using /usr/local/bin/ffmpeg:

  exec /usr/bin/ffmpeg $(echo "$@" | sed 's/44100/44100 -af aresample=async=1/')

No crackling at all!
Thank you very much!! :slight_smile: :+1:


@oscarb thanks for your feedback! Where can I put this “sed code” when I use this implementation How do I change YOUTUBE Live Stream to another RTMP server url? ?

bbaldino already patched the source. If you do not want to compile it yourself you can wait for a next release to be installed with apt (on ubuntu).
As a tmp workaround you can wrap ffmpeg as I mentioned above on your jibri server (prob. ubuntu/debian?). Just put the two lines of code:

exec /usr/bin/ffmpeg (echo “@” | sed ‘s/44100/44100 -af aresample=async=1/’)

in the file /usr/local/bin/ffmpeg (on your jibri server).
Make this file excutable for all: chmod 755 /usr/local/bin/ffmpeg
Restart jibri: systemctl restart jibri
That’s all.

ok, thanks @oscarb. I’m using a bash script implemented in this post How do I change YOUTUBE Live Stream to another RTMP server url?.

I’m trying to use it with (echo “@” | sed ‘s/44100/44100 -af aresample=async=1/’), but when I put exec $COMMAND (echo “@” | sed ‘s/44100/44100 -af aresample=async=1/’) it doesn’t work. I’ll try other ways while the docker image of jibri is updated.

For that particular script do in stead of

COMANDO=$(echo "$COMANDO" | sed 's/44100/44100 -af aresample=async=1/')
1 Like

@oscarb many thanks!! It worked!

Hi @oscarb I can’t get it to work. I did as you discribed. The streams does not even strart anymore. When I remove the file it works again. First I tought it was the " and the ’ but it did not word when I typed it all over. How log before I can update it with apt in Ubuntu? I am running it on Ubuntu 16.04. Is there something else I can try?

I can confirm that adding -af aresample=async=1 to ffmpeg command solved the problem. Now there is no cracking sound in live streaming. Thanks @bbaldino for this solution!

Tiny suggestion: It would be so easy to do tests if we get ffmpeg parameters from a config file. I wish to see this in upcoming releases =)


I must apologize since I just realized that this thread belongs to “instal and config” and “jibri”, so its solution doesn’t solve my problem, being that I connect to jitsi using the app for android and the browsers in my notebook.

Should I create a new thread with my problem in another part of the forum, or will the solution found here have any effect on solving the problem in general?

Of course, thank you very much for your answer.
I don’t speak English, so I use a translator.
I’m sorry if something is not understood.

Hi @rjgout, try again. The quotes in the post are now correct… Sorry for the inconvenience.

Yes! It works, Thanks a bunch! I see you added a $.

No, I used 'preformatted text' in stead of


so the quotes are now correct :wink:

Nice it works for you now :+1:

The problem was solved, since Saturday June 13 that no noises appear in my transmission.
Thank you so much to those who worked on it.

1 Like

This has been solved in this commit!

Thanks to all!

Finally had time to test, and as everyone is saying, it is fixed! Even combines with using pulse! Very amazing. Huge thanks to everyone!

Will use the wrapper script for now for both noise and pulse support, and hope pulse also makes into mainline, as it is much better when you do not need non AWS kernel when on AWS :smiley: And also will have to wait for debian package to be built.

In any case, super greatfull!

When will this commit be put in the stable release?

We are having the same issue, but we can’t recompile jibri, how can we get those changes? any idea on updating a production jibri without losing settings? @damencho @cad0p

Read through thread, you do not need to compile anything, just a wrapper script for ffmpeg.

@damencho @bbaldino Have you made a new debian jibri package for this for the jitsi-meet debian/ubuntu repository yet?

I ask because I have not received an update or upgrade notification in ubuntu and I’m still experiencing crackling on all my videos.