Livestream option missing

I made a fresh install and enabled jibri also with the latest version. Post configuring the jibri, the stream option is missing in the menu. I have tried twice the fresh install in both place I do get the same problem. Looking at the jibri there seems no problem at all,

tail: no files remaining
root@hangout:/var/log/jitsi/jibri# tail -f log.0.txt
2021-01-19 05:46:39.407 INFO: [1] org.jitsi.jibri.Main.main() Using port 2222 for HTTP API
2021-01-19 05:46:39.410 WARNING: [27] org.jitsi.xmpp.mucclient.MucClient.log() Disabling certificate verification!
2021-01-19 05:46:39.718 INFO: [27] org.jitsi.xmpp.mucclient.MucClient.log() Connected.
2021-01-19 05:46:39.718 INFO: [27] org.jitsi.xmpp.mucclient.MucClient.log() Logging in.
2021-01-19 05:46:39.798 INFO: [27] org.jitsi.xmpp.mucclient.MucClient.log() Joined MUC: jibribrewery@internal.auth.hangout.domain.com
2021-01-19 05:47:39.405 FINE: [18] org.jitsi.jibri.webhooks.v1.WebhookClient.invokeSuspend() Updating 0 subscribers of status
2021-01-19 05:48:39.405 FINE: [18] org.jitsi.jibri.webhooks.v1.WebhookClient.invokeSuspend() Updating 0 subscribers of status
2021-01-19 05:49:39.405 FINE: [18] org.jitsi.jibri.webhooks.v1.WebhookClient.invokeSuspend() Updating 0 subscribers of status
2021-01-19 05:50:39.405 FINE: [18] org.jitsi.jibri.webhooks.v1.WebhookClient.invokeSuspend() Updating 0 subscribers of status
2021-01-19 05:51:39.405 FINE: [18] org.jitsi.jibri.webhooks.v1.WebhookClient.invokeSuspend() Updating 0 subscribers of status

image

You have to enable the button in your interface_config.js.

1 Like

It’s enabled already. Before configuring the jibri the button was visible, after installing the jibri this button doesn’t appear.In the latest version of jitsi the live stream button used to be visible by default (yet it needs jibri to be installed to get it worked), but after configuring the jibri it misses the button.

Have you switched on this: jitsi-meet/config.js at 23574e9edc5abb13423d2b442c405c648640afc3 · jitsi/jitsi-meet · GitHub ?

1 Like

its already enabled. You can notice the below image, along with the livestream link other option which used to be appear also missing after we join the call, i thought it could be javascript error, but couldn’t find any javascript error also in console.
image

Probably you already checked this but to be sure: are you moderator in the session?

1 Like

Yes, I m the moderator. Again I’m trying to setup from beginning in the new server. I’m checking at each step when this live button is missing, will update sooner on the forum the result.

I was using the ubuntu20.04 on aws, in this this always end up the same issue. When I switch to ubuntu 18.04 it works very well at the first attempt.