Livestream error

Hello Guys.

I can’t start livestreams
After I paste my like stream key from youtube, this erros happens:

“Failed to start a livestream”

wich logs should I look for errors?

Is this on meet.jit.si? If so it may be that there aren’t any resources available right now.

No, is on my own deployment.

Which logs I can paste here for some help?

@Igor_Ayres, this is a Jibri function, so Jibri logs would be ideal. You might also want to post your Jicofo log, just in case.

Hi.

I don’t think I have jibri installed, its this required for livestreams?

I just follow this tutorial:

this is my /var/log/jitsi directory:

I suspected as much reading your earlier post, but I didn’t want to sound like I was pointing out the obvious. Yes, you need Jibri installed to enable recording and livestreaming. I recommend this post as a guide for Jibri installation - it’s one of the better ones I’ve seen.

I just install jibri, and I gettin this erros on jicofo’s log

Blockquote
Jicofo 2020-10-24 14:32:26.168 INFO: [34] org.jitsi.jicofo.recording.jibri.JibriRecorder.log() Failed to start a Jibri session, no Jibris available
Jicofo 2020-10-24 14:33:30.589 SEVERE: [29] org.jitsi.jicofo.recording.jibri.JibriSession.log() Unable to find an available Jibri, can’t start

My 5222 TCP port its open

One thing that I note, thats I don’t have this file:

/etc/jitsi/jibri/config.json

How can I create then?

On this directory, tha’ts all that I see:

jibri.conf logging.properties pjsua.config xorg-video-dummy.conf

No need to this file on the new installation.

Did you customize jibri.conf according to your environment?

1 Like

Yes I just finished to configure my jibri.conf file (just replace ‘mydomain’ information):

// An example file showing the fields for the XMPP environment config.

{
environments = [
{
// A user-friendly name for this environment
name = “mydomain”

        // A list of XMPP server hosts to which we'll connect
        xmpp-server-hosts = [ "mydomain.com.br" ]

        // The base XMPP domain
        xmpp-domain = "mydomain.com.br"

        // The MUC we'll join to announce our presence for
        // recording and streaming services
        control-muc {
            domain = "internal.auth.mydomain.com.br"
            room-name = "JibriBrewery"
            nickname = "jibri"
        }

        // The login information for the control MUC
        control-login {
            domain = "mydomain.com.br"
            username = "jibri"
            password = "Jibr1P@ssw0rd$$"
        }

        // An (optional) MUC configuration where we'll
        // join to announce SIP gateway services
        sip-control-muc {
            domain = "internal.auth.mydomain.com.br"
            room-name = "JibriBrewery"
            nickname = "jibri"
        }

        // The login information the selenium web client will use
        call-login {
            domain = "mydomain.com.br"
            username = "recorder"
            password = "Rec0rderP@ssw0rd$$"
        }

        // The value we'll strip from the room JID domain to derive
        // the call URLstrip-from-room-domain = ""

        // How long Jibri sessions will be allowed to last before
        // they are stopped.  A value of 0 allows them to go on
        // indefinitely
        usage-timeout = 3 hour

        // Whether or not we'll automatically trust any cert on
        // this XMPP domain
        trust-all-xmpp-certs = true
    }
]

}

There are some problem in the config file. Check it according to this sample

1 Like

Hi emrah

Still not working…

jibri {
id = ""
single-use-mode = false

recording {
    recordings-directory = "/recordings"
    //finalize-script = "/usr/local/bin/finalize_recording.sh"
}

chrome {
    flags = [
        "--use-fake-ui-for-media-stream",
        "--start-maximized",
        "--kiosk",
        "--enabled",
        "--disable-infobars",
        "--autoplay-policy=no-user-gesture-required"
    ]
}

api {
    http {
        internal-api-port = 8001
        external-api-port = 8002
    }

    xmpp {
        environments = [{
            name = "Live Paco"
            xmpp-server-hosts = ["mydomain.com.br"]
            xmpp-domain = "mydomain.com.br"

            control-muc {
                domain = "internal.auth.mydomain.com.br"
                room-name = "JibriBrewery"
                nickname = "jibri-nickname"
            }

            control-login {
                domain = "auth.mydomain.com.br"
                username = "jibri"
                password = "Jibr1P@ssw0rd"
            }

            call-login {
domain = "recorder.mydomain.com.br"
                username = "recorder"
                password = "Rec0rderP@ssw0rd"
            }

            strip-from-room-domain = "conference."
            usage-timeout = 0
            trust-all-xmpp-certs = true
        }]
    }
}

stats {
    enable-stats-d = true
}

call-status-checks {
    no-media-timeout = 30 seconds
    all-muted-timeout = 5 minutes
    default-call-empty-timeout = 30 seconds
}

I’m getting the same error on Jicofo’s log:
Jicofo 2020-10-26 16:55:55.445 SEVERE: [108] org.jitsi.jicofo.recording.jibri.JibriSession.log()
Unable to find an available Jibri, can’t start
Jicofo 2020-10-26 16:55:55.446 INFO: [108] org.jitsi.jicofo.recording.jibri.JibriRecorder.log() Failed to
start a Jibri session, no Jibris available

IT WORKS!!! I’m using
systemctl enable --now jibri

I just run
systemctl start jibri