LIve Streaming not working

Should I add these accounts to Prosody again and restart prosody?

prosodyctl register jibri auth.crweb.sxcs.in jibriauthpass

prosodyctl register recorder recorder.crweb.sxcs.in jibrirecorderpass

No, if you have added once, it is fine.

you have deployed this on AWS, I hope your security rules does not block the Jibri <-> Jitsi connections. Please allow everything once, and restart the services, and check if the problem persists.

I have allowed all traffic. inbound and outbound. for both - Jitsi and Jibri.

sg

How to load the following at system startup?

jibri-xorg
jibri-icewm
jibri

I mean what is the command?

Cannot find this service - jibri-xmpp if I run sudo service jibri-xmpp status.

I think this is your problem:

Jicofo 2019-01-16 16:41:01.950 SEVERE: [17] org.jitsi.jicofo.xmpp.BaseBrewery.start().196 Failed to create room: JibriBrewery@internal.auth.crweb.sxcs.in

I’ve seen it reported before that if Jibri is first to create the MUC, then jicofo can’t join. Try this:

Stop Jibri
Stop Jicofo
Restart Prosody
Start Jicofo
Start Jibri

and see if that works. Attach Jicofo and Jibri logs from when you try.

I did what you said. But still same error. Here is the log.

jicofo-log.txt (680.3 KB)
log.0.txt (3.1 KB)

See from line number - 3845 in Jicofo log. Created a room called - jkl.

Looks like Jibri can’t connect to the xmpp server at all, so there are definitely some problems there. @damencho will restarting prosody not fix the MUC creation perms problem? Or can something else cause that?

Well then it depends who will be the first to re-join.

Right, but he tried Jicofo starting first and still saw the issue looks like.

Is there any solution for it?