Live streaming failed to start

Hello,
First time jitsi user, successfully setup jisti self hosted on google cloud, able to create calls works as expected.
I want to live stream to youtube. I enabled it in config.js and it appears in the menu - when I try to stream I get an error “Live streaming failed to start”
lsfailed
Please help me troubleshoot this issue.
Thanks.

Related logs are in /var/log/jitsi/jibri

Hi I have the same issue, I dont have a /jibri directory

drwxrwx— 2 jvb jitsi 4096 Aug 24 06:25 .
drwxrwxr-x 12 root syslog 4096 Aug 24 06:25 …
-rw-r----- 1 jicofo jitsi 16983 Aug 24 16:58 jicofo.log
-rw-r----- 1 jicofo jitsi 32196 Aug 24 06:25 jicofo.log.1
-rw-r----- 1 jicofo jitsi 13442 Aug 23 06:25 jicofo.log.2.gz
-rw-r----- 1 jicofo jitsi 362 Aug 22 06:25 jicofo.log.3.gz
-rw-r----- 1 jicofo jitsi 361 Aug 21 06:25 jicofo.log.4.gz
-rw-r----- 1 jicofo jitsi 361 Aug 20 06:25 jicofo.log.5.gz
-rw-r----- 1 jicofo jitsi 359 Aug 19 06:25 jicofo.log.6.gz
-rw-r----- 1 jicofo jitsi 359 Aug 18 06:25 jicofo.log.7.gz
-rw-r----- 1 jvb jitsi 23120491 Aug 24 17:24 jvb.log
-rw-r----- 1 jvb jitsi 106619778 Aug 15 06:25 jvb.log.1
root@meet:/var/log/jitsi#

has anyone had this to work at all?

are you the one trying to send to youtube or are you setting it up for another person

its works on the jitsi, main site

and you have seen it work? how are you interfacing with jitsi-app or desktop?

just via a browser

ok…well there are alot of moving pieces have you thought about doing it on a different device?

https://nerdonthestreet.com/wiki?find=Set+Up+Jibri+for+Jitsi+Recording%3Aslash%3AStreaming this is a good guide

also you need make sure the kernel supports snd_aloop ubuntu 16.04 does if you use anything else its not easy to get it installed.

yea i believe it would like to see it working

it must work somewhere

this is where i am getting now

root@meet-mogokdhamma:/var/log# service jibri status

  • jibri.service - Jibri Process
    Loaded: loaded (/etc/systemd/system/jibri.service; enabled; vendor preset: enabled)
    Active: failed (Result: start-limit-hit) since Tue 2020-08-25 23:17:21 UTC; 25s ago
    Process: 19540 ExecStop=/opt/jitsi/jibri/graceful_shutdown.sh (code=exited, status=7)
    Process: 19538 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=127)
    Main PID: 19538 (code=exited, status=127)

also get this from the syslog file and Jibri tries to start

Aug 25 23:31:13 meet-mogokdhamma systemd[1]: Started Jibri Process.
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: Exception in thread “main” java.lang.NoClassDefFoundError: javax/annotation/Priority
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: #011at org.glassfish.jersey.model.internal.ComponentBag.modelFor(ComponentBag.java:529)
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: #011at org.glassfish.jersey.model.internal.ComponentBag.lambda$registerModel$10(ComponentBag.java:454)
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: #011at org.glassfish.jersey.internal.Errors.process(Errors.java:292)
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: #011at org.glassfish.jersey.internal.Errors.process(Errors.java:274)
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: #011at org.glassfish.jersey.internal.Errors.process(Errors.java:205)
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: #011at org.glassfish.jersey.model.internal.ComponentBag.registerModel(ComponentBag.java:446)
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: #011at org.glassfish.jersey.model.internal.ComponentBag.register(ComponentBag.java:357)
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: #011at org.glassfish.jersey.model.internal.CommonConfig.register(CommonConfig.java:448)
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: #011at org.glassfish.jersey.server.ResourceConfig.register(ResourceConfig.java:428)
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: #011at org.jitsi.jibri.MainKt$launchHttpServer$jerseyConfig$1.(Main.kt:164)
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: #011at org.jitsi.jibri.MainKt.launchHttpServer(Main.kt:162)
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: #011at org.jitsi.jibri.MainKt.main(Main.kt:147)
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: Caused by: java.lang.ClassNotFoundException: javax.annotation.Priority
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: #011at jdk.internal.loader.BuiltinClassLoader.loadClass(java.base@9-internal/BuiltinClassLoader.java:366)
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: #011at jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(java.base@9-internal/ClassLoaders.java:184)
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: #011at java.lang.ClassLoader.loadClass(java.base@9-internal/ClassLoader.java:419)
Aug 25 23:31:14 meet-mogokdhamma launch.sh[20303]: #011… 12 mo

got past that now install a new version of jibri and its running with errors