Linux Mint 19 MATE - Unable to launch Jitsi


#1

Hello All!
I am using Linux Mint 18 MATE and I installed Jitsi from here following the command line steps.
I was able to install the full suite but I am unable to see Jitsi installed (icon).
I rebooted the system but the issue remains.
Is there any way to see if the installation actually took place and if there is a way to troubleshoot and/or launch Jitsi via command line?

Thanks for your help, Ron


#2

Are you trying to install Jitsi Desktop or jitsi-meet?
If it is Jitsi Desktop you should be able to start it from the terminal with jitsi.


#3

@damencho
As mentioned, the full suite.
I tried in terminal > jitsi and get a terminal message: > jitsi: command not found
I tried > jitsi-meet and I get the same message.
Thanks for helping, any additional suggestion is very welcome, Ron


#4

apt-get install jitsi-meet will install jitsi-meet-web, jicofo, jvb, xmpp server and it will auto-start the services and you can access them by opening a browser and going to “https://host_name”, where ‘host_name’ is the domain you have entered when installing jitsi-meet, it should have a valid DNS record pointing to the machine where you are installing it.


#5

@damencho
OK, maybe I got it.
When I installed the full suite there was no request of a host-name / domain.
Not sure if this is a bug.
My intent is to have Jitsi as a basic desktop app on my Linux Mint 19.
I had in the past Jitsi on older Linux Mint versions and I never had an issue.
Based on your info see:
Basic Jitsi Meet install
Add the repository

I tried: echo ‘deb https://download.jitsi.org stable/’ >> /etc/apt/sources.list.d/jitsi-stable.list as it is and using sudo and I got “permission denied”
See:
sudo echo ‘deb https://download.jitsi.org stable/’ >> /etc/apt/sources.list.d/jitsi-stable.list
bash: /etc/apt/sources.list.d/jitsi-stable.list: Permission denied

Not sure what is going on.
My interest is Jitsi desktop for Linux Mint 19.
Let me know where to get it and I will check and see if I can get it to install.

Thanks, Ron


#6

On the page you were reading there is a section: “Jitsi Desktop stable build line” with links for different operating systems.
Is see there is are some links that point the same page, I will fix them tomorrow.
So you should do:

sudo wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | sudo apt-key add -
sudo sh -c "echo 'deb https://download.jitsi.org stable/' > /etc/apt/sources.list.d/jitsi-stable.list"
sudo apt-get -y update
sudo apt-get -y install jitsi

to install Jitsi Desktop.


#7

@damencho
Completed steps as you recommended but the installation gets stuck on Jitsi splash progressive bar at NimbuzzAvatars.
I launched Jitsi via terminal, see verbose final portion of a long file, I am not authorized and allowed to attach files:

at java.base/java.lang.Thread.run(Thread.java:844)
org.osgi.framework.BundleException: Unable to resolve net.java.sip.communicator.shutdowntimeout [76](R 76.0): missing requirement [net.java.sip.communicator.shutdowntimeout [76](R 76.0)] osgi.wiring.package; (osgi.wiring.package=net.java.sip.communicator.util) [caused by: Unable to resolve net.java.sip.communicator.service.util [97](R 97.0): missing requirement [net.java.sip.communicator.service.util [97](R 97.0)] osgi.wiring.package; (osgi.wiring.package=javax.imageio)] Unresolved requirements: [[net.java.sip.communicator.shutdowntimeout [76](R 76.0)] osgi.wiring.package; (osgi.wiring.package=net.java.sip.communicator.util)]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.base/java.lang.Thread.run(Thread.java:844)
I hope this helps, cheers.
Ron


#8

Can you try unstable, does it work for you?
You just need to:

sudo sh -c "echo 'deb https://download.jitsi.org unstable/' > /etc/apt/sources.list.d/jitsi-unstable.list"
sudo apt-get -y update
sudo apt-get -y install jitsi

#9

@damencho
With the unstable I get this from terminal:


sudo apt-get -y install jitsi
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
jitsi : Depends: libavcodec57 but it is not going to be installed or
libavcodec-ffmpeg56 but it is not installable
E: Unable to correct problems, you have held broken packages.

Ron


#10

Isn’t this Ubuntu? These files should be available in Ubuntu 16.04 and later.


#11

@damencho
As mentioned earlier, it is Linux Mint 19 MATE, not sure why those files are not there, let me try to install them and try to install the unstable again.

Let me add a few notes here:
I got from Synaptic: libavcodec57 - the other file libavcodec-ffmpeg56 does dot exist.
Installing libavcodec57 removed some additional packages (not sure you are interested to know which, I hope it does not have a negative impact to other apps though).
I ran Jitsi from terminal, it seems working (unstable) as well as from the menu.
What next, should I keep this version and if there are updates would this unstable version get the updates?
Thanks for your help, Ron


#12

The unstable branch is the current version that is getting updates, and one of these versions one day will become stable and then the stable will be updated.


#13

@damencho Thanks for the info.
I was able to set my SIP account as usual with Jitsi, but I am noticing that when I close the display (not ‘quit’) the app closes completely instead of running in the background as it was doing in the past. It seems an odd behavior… Is this a known issue?
Cheers! Ron


#14

There is a setting in preferences about that, try it, does it changes anything?


#15

Yes better, I went to Options | General | Start up | checked “Minimize the main window…”
Thanks!
Ron