Linked Jitsi-meet-electron with my own Jitsi installation


#1

Hi today i tried to link my Jitsi-meet-electron app and my Jitsi installation because i just read if i install this client on a pc i can use my web browser to remote controll this pc.
But i read this https://github.com/jitsi/jitsi-meet-electron and i don’t really understand what i need to do.
I’m using Apach2.
So where need i add this lines :

location /external_api.js {
    alias /usr/share/jitsi-meet/libs/external_api.min.js;
}

Ty for your time


#2

Those lines are for nginx. If you are using Apache you need:

  Alias "/external_api.js" "/usr/share/jitsi-meet/libs/external_api.min.js"
  <Location /external_api.js>
    Require all granted
</Location>

Cheers,


#3

Ty for your response but where nees i add this lines pls.


#4

Where your apache is configured for jitsi-meet:
/etc/apache2/sites-available/yourdomain.com.conf and you need to reload/restart apache.


#5

I have the same question but it is about where the line should go on nginx.
Is it the nginx.conf? If so, where exactly?
I am new to Linux and nginx.
My nginx.conf starts like this:

user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
worker_connections 768;
# multi_accept on;
}

http {

    ##
    # Basic Settings
    ##

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 65;
    types_hash_max_size 2048;
    # server_tokens off;

    # server_names_hash_bucket_size 64;
    # server_name_in_redirect off;

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    ##
    # SSL Settings
    ##

    ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE

Can anyone help? Thanks!


#6

Sorry, I just find out which .conf file that line should go to. but I am not sure where exactly in the file.


#7

/etc/nginx/sites-available/yourserver.com.conf

inside:

server {
    listen 443 ssl default_server;
.....
There should be other location directives and you should reload/restart nginx.

#8

Thank you for the quick response.
I added the line to the block you mentioned in the .conf file and restarted nginx. However, I am still not able to change the address in the electron to my server address which is an pure IP address.
What could be the problem?


#9

You cannot use an IP address. You must use a domain. SSL is a mandatory requirement (browsers enforce this) so an IP address won’t work.