Lib Jitsi Meet: mute then unmute leads to frozen remote video track

Hi,

When I mute my local video track and then unmute it, the other clients do receive the TRACK_MUTE_CHANGED event, but the video remains frozen.

It works fine with the audio track.

How do I check what is wrong?

Thanks!

1 Like

I found out that using this url creates the freeze issue: https://meet.jit.si/libs/lib-jitsi-meet.min.js
Using the lib-jitsi.meet.min.js provided as part of the lib example works fine: https://github.com/jitsi/lib-jitsi-meet

Hi did you have in logs something like this?
2020-09-21T12:29:59.093Z [modules\connectivity\ParticipantConnectionStatus.js] <g.figureOutConnectionStatus>: Figure out conn status for 46cff3c0, is video muted: false is active(jvb): true video track frozen: true p2p mode: true is in last N: true currentStatus => newStatus: active => interrupted

If yes it is possible that you have old JVB version JVB Endpoint connection interrupted Periodic

I am facing the same problem. Also if I use a fresh build of the library from https://github.com/jitsi/lib-jitsi-meet .
On the side, that is receiving the event that a remote track was unmuted, I also get an endpoint changed its status to “interrupted” event. Does this indicate, that the sender stops sending camera data?

Facing the same issue here. Tried with fresh build also and the problem persists.
Has anyone tried rolling back to an older version of the library?
I cannot find any indication about the isue on the logs also.

for anyone that stumbles upon this, switching back to an earlier version of the library fixes this issue.

Yes I came up with the same solution: use an older version of the lib :frowning:

To which version did you guys switch back?

1 Like

@Theodore_Giossis and @AymericG what version did you all end up using?

1 Like

This is part of the package json, so i guess 0.0.0 ? :slight_smile:

“name”: “lib-jitsi-meet”,
“version”: “0.0.0”,
“description”: “JS library for accessing Jitsi server side deployments”,
“repository”: {
“type”: “git”,
“url”: “git://github.com/jitsi/lib-jitsi-meet”
},
“keywords”: [
“jingle”,
“webrtc”,
“xmpp”,
“browser”,
“jitsi”
],
“author”: “”,
“readmeFilename”: “README.md”,
“dependencies”: {
@jitsi/sdp-interop”: “0.1.13”,
@jitsi/sdp-simulcast”: “0.2.1”,
“async”: “0.9.0”,
“current-executing-script”: “0.1.3”,
“jitsi-meet-logger”: “github:jitsi/jitsi-meet-logger#6fff754a77a56ab52499f3559105a15886942a1e”,
“js-utils”: “github:jitsi/js-utils#446497893023aa8dec403e0e4e35a22cae6bc87d”,
“lodash.isequal”: “4.5.0”,
“sdp-transform”: “2.3.0”,
“strophe.js”: “1.2.16”,
“strophejs-plugin-disco”: “0.0.2”,
“webrtc-adapter”: “github:webrtc/adapter#1eec19782b4058d186341263e7d049cea3e3290a”,
“yaeti”: “1.0.1”
},

@aljen: for me the latest version that works is: https://github.com/jitsi/lib-jitsi-meet/releases/tag/jitsi-meet_4960

We faced the same issue and downgraded to the older version of lib-jitsi-meet

1 Like

What version @nemaniarjun?

Hi, I use the script tag to embed lib jitsi meet in my project, how do i downgrade?

@sowmya_subramaniam just download the source from the link above (https://github.com/jitsi/lib-jitsi-meet/releases/tag/jitsi-meet_4960) and build lib-jitsi-meet on your own with “npm install” (according to the explanation from https://github.com/jitsi/lib-jitsi-meet).
Then you can include the lib-jitsi-meet.min.js in your script tag (instead of the URL pointing to https://meet.jit.si/libs/lib-jitsi-meet.min.js.
So instead of:

[script src=“https://meet.jit.si/libs/lib-jitsi-meet.min.js”></script]

use the path to your own javascript file:
E.g.: [script src=“scripts/lib-jitsi-meet.min.js”></script]

2 Likes

We built from master, so don’t have versioning for it. Sorry.

Thank you! Finally got it working!

@Florian_Santner You are a lifesaver. It is working for me now. I have been observing this issue all of a sudden for some reason which did not occur before. I tried to resolve it using different methods to no avail. Your solution worked finally. Thanks!

1 Like

Thank god, i spent 2 days for muted track debugging.

Even though stream was active but track.muted = true which should be false.

yes, thats true, the same thing and debugging result, video unmute, but track.muted return true…