Lib-jitis-meet is now over 750Kb - Cannot be compile by webpack anymore

Hi,
With webpack 4.26.1 and last lib-jitis-meet commit. The jitsi library got over 750 Kb.
This is a size limit that makes webpack compilation of such library failing.
See logs below.
Would you have any quick fix/idea to decrease the size of the library so we can compile it?
I created issue in Github too https://github.com/jitsi/lib-jitsi-meet/issues/1071
Thank you
Fabrice

Version: webpack 4.26.1
Child
    Hash: 95d397e6d99d24a97a5c
    Time: 15836ms
    Built at: 06/04/2020 22:22:12
                     Asset      Size  Chunks                    Chunk Names
     lib-jitsi-meet.min.js   756 KiB       0  [emitted]  [big]  lib-jitsi-meet
    lib-jitsi-meet.min.map  2.71 MiB       0  [emitted]         lib-jitsi-meet
    Entrypoint lib-jitsi-meet [big] = lib-jitsi-meet.min.js lib-jitsi-meet.min.map
      [2] ./JitsiConferenceEvents.js 9.25 KiB {0} [built]
      [3] ./modules/browser/index.js 98 bytes {0} [built]
      [5] ./modules/statistics/statistics.js 26.3 KiB {0} [built]
      [7] ./service/statistics/AnalyticsEvents.js 18.6 KiB {0} [built]
      [9] ./service/RTC/MediaType.js 178 bytes {0} [built]
     [11] ./modules/util/GlobalOnErrorHandler.js 2.37 KiB {0} [built]
     [12] ./modules/RTC/RTC.js 37 KiB {0} [built]
     [13] ./JitsiTrackErrors.js 2.51 KiB {0} [built]
     [15] ./JitsiTrackEvents.js 1.31 KiB {0} [built]
     [16] ./JitsiTrackError.js 5.98 KiB {0} [built]
     [17] ./JitsiConferenceErrors.js 2.12 KiB {0} [built]
     [20] ./modules/detection/DetectionEvents.js 2.49 KiB {0} [built]
     [21] ./modules/videosipgw/VideoSIPGWConstants.js 1.44 KiB {0} [built]
    [129] ./index.js 160 bytes {0} [built]
    [130] ./JitsiMeetJS.js 24.7 KiB {0} [built]
        + 138 hidden modules
    
    ERROR in asset size limit: The following asset(s) exceed the recommended size limit (750 KiB).
    This can impact web performance.
    Assets: 
      lib-jitsi-meet.min.js (756 KiB)
    
    ERROR in entrypoint size limit: The following entrypoint(s) combined asset size exceeds the recommended limit (750 KiB). This can impact web performance.
    Entrypoints:
      lib-jitsi-meet (756 KiB)
          lib-jitsi-meet.min.js
    
    
    ERROR in webpack performance recommendations: 
    You can limit the size of your bundles by using import() or require.ensure to lazy load some parts of your application.
    For more info visit https://webpack.js.org/guides/code-splitting/

Hi @damencho,
Would you or someone have an idea about how to go over such new compiling issue?
Thank you
Fabrice

Hello, did you try to play with these settings ?

/**

  • Build a Performance configuration object for the given size.
  • See: https://webpack.js.org/configuration/performance/
    */
    function getPerformanceHints(size) {
    return {
    hints: minimize ? ‘error’ : false,
    maxAssetSize: size,
    maxEntrypointSize: size
    };
    }

Thank you @gpatel-fr
@anshad suggested me in Github Issues to remove the commit ID like below:
“lib-jitsi-meet”: “github:jitsi/lib-jitsi-meet”
and it worked…
Thank you for your help and feedback!!
Fabrice