Latest unstable JVB2 is broken with three more participants

No I could not see it… I am still looking into it, but I doubt that will ever happen. :slight_smile: Plus where will I see it? On Command/shell prompt? Will it pop up as a message or a comment?

And what is “nc -l 10000 -u” suppose to do? I am running this command on server and it jiust gets stuck, waiting and nothing happens.

What in “echo “123” | nc -u server.ip.address 10000” the server ip address should be public IP and not the local IP. Right?

You have my public ip, pls feel free to send me a test message.

BTW, if port was an issue, how come first 2 people are able to join? Should it not block everyone? Just curious?

Many Thanks,
Rav

Boom… Got it working. :slight_smile:

Put the command, “echo “Test” | nc -u <my.public.ip.address> 10000” and got the “Test” message displayed on the server.

Glad that we are 1 step further… now what next should I do?

Many Thanks,
Rav

If you have done that from internet then it means port forwarding is working, and jvb should be running fine using that port.

Yeah, going to try it now… If it works, need to check, what I actually did and what was the issue.

Will keep you posted. Pls give me some time.

Many Thanks,
Rav

I just tested your instance and it works with 3 participants.

2 participants work as they are p2p and do not go through the bridge most of the time.

Perfecto… Looks like a dream now. Just tried with 4 friends and myself… 5 people on a mixture of laptop and phone (iOS and Android) and it worked perfectly fine.

However, I am still not sure what changes I made which made port 10000 work - everything seems to be as it is. I will do more digging and if I find some sensible information, I will inform you and everyone here in the group - so that it can help others.

Many Thanks,
Rav

Apologies about my earlier rant about the community support, but this is exactly how it perseved the support to be. This is how it should be - a perfect and very helpful team trying to ensure everyone can get the required help and support so that everyone can use and enjoy the product.

And in return I promise that I will be around to help others based on what I have learnt so far. And also ask more questions as I plan to take this to next level.

Many Thanks,
Rav

I’m facing the same issue. Please help me to rectify it

Hi @Jyotirmoy, if you can explain me your issues in more/exact details, based on whatever little I know, I will try my best to assist you accordingly.

Thx: Rav

I had a similar issue, turned out, I had webmin installed, I did change the port of the webmin, however it was still listening on port 10000, remove webmin and now using ajenti that runs on a complete different port. Everything started working after that.

Does webmin listen TCP/10000? The Jitsi videobridge listens UDP/10000. They should work together.

I think it does use UDP as well as per https://doxfer.webmin.com/Webmin/Webmin_Servers_Index

“All versions of Webmin since 0.75 listen on UDP port 10000 for the broadcast and scan packets sent out by this module, and reply with their hostname, port number and SSL mode. A server will not be found if a firewall is blocking this port or if UDP listening has been turned off for security reasons.”

Warm Regars
Nirav

1 Like

@raviktiwari
Can you explain how to did you able to get the commands working

sudo service jitsi-videobridge2 stop
command ran successfully
nc -l 10000 -u
got stuck nothing happened
echo “123” | nc -u 10000
this is also same stuck nothing happened

can you provide complete step you followed to make it work

Advance thanks for your help

This you executed on the jvb machine.

This you need to execute from some machine that is on Internet, not in the same network as jvb.

If nothing is happening, this means your port forwarding is not working or you have a firewall that blocks udp packets to reach jvb.

1 Like

sudo ufw status verbose
the above command is showing everything allowed

To Action From


80/tcp ALLOW IN Anywhere
443/tcp ALLOW IN Anywhere
4443/tcp ALLOW IN Anywhere
10000/udp ALLOW IN Anywhere
22/tcp ALLOW IN Anywhere
10000/tcp ALLOW IN Anywhere
22/tcp (OpenSSH) ALLOW IN Anywhere
10000:20000/udp ALLOW IN Anywhere
80,443/tcp ALLOW IN Anywhere
5000,10000/udp ALLOW IN Anywhere
80/tcp (v6) ALLOW IN Anywhere (v6)
443/tcp (v6) ALLOW IN Anywhere (v6)
4443/tcp (v6) ALLOW IN Anywhere (v6)
10000/udp (v6) ALLOW IN Anywhere (v6)
22/tcp (v6) ALLOW IN Anywhere (v6)
10000/tcp (v6) ALLOW IN Anywhere (v6)
22/tcp (OpenSSH (v6)) ALLOW IN Anywhere (v6)
10000:20000/udp (v6) ALLOW IN Anywhere (v6)
80,443/tcp (v6) ALLOW IN Anywhere (v6)
5000,10000/udp (v6) ALLOW IN Anywhere (v6)
did i miss anything?

It got stuck after running the command if it is blocking means what commands i need to use can you provide entire setup at once to check all the possible solution to so that i can check entirely

@damencho

Have you fixed your port forwarding on your NATting device?

i run the below command
ip -4 addr show scope global
output: ens5: <broadcast,multicast,up,lower-up> mtu 9001 qdisc mq state UP group default qlen 1000
inet <ipaddress/20> brd XXX.XX.XX.XXX scope global dynamic ens5
valid_lft 2055sec preferred_lft 2055sec

Sorry for asking again how to check that port forwarding can you elaborate??
@damencho

Does this happen, everything works fine when two people in the room, as soon as the third person joins, audio / video stops functioning.

If you are running webmin or any other control panel that uses port 10000 then please uninstall it and that should solve the issue. I had the same issue with Webmin running, removed it and all was good.

Why will you remove webmin? Webmin is far more critical than Jitsi. I would rather uninstall Jitsi - and install it somewhere else on may be a small/test server… I have recently found out that Java and JVB are massively resource hungry so installing it on production server where you are hosting main domains is a big risk in my opinion.

Anyways, if you are using Virtualmin/Webmin, just change Virtualmin port from 10000 to something else… But to be honest it does not interfere because Webmin works on 10000 TCP and Jitsi need 10000 UDP… But yes as a beginner when you are trying out Jitsi first time and testing your stuff, just to avoid any confusion, you can just change virtualmin port to something else like: 9876 and then try everythint out and when you have understood it’s working and are confident, you can put it back to 10000 (it will not clash) or leave it as it is.

You have opened far too many ports mate… It is not worth it, just to get a simple application working. And anyways Jitsi does not ask you to open up so many ports… so pls don’t get desperate.

I have already explained to you what to do but if you are still stuck, send me a PM with your email id and WhatsApp number and we can probably work together on Team viewer… happy to assist to best of my ability and don’t worry I won’t charge you… I am always happy to share my learning to help others.

As @damencho said you will need at least 2 computers on 2 different networks both facing internet to be able to do your testing … so if you don’t have 2 machines, we can use mine as 2nd.

By the way which OS and firewall you are using?

Many Thanks,
Rav