Latest unstable JVB2 is broken with three more participants

So jvb advertises the ip correctly:

Normally when this happens, people are having problem with either port forwarding or firewall.

To test port forwarding you need to execute the nc client from Internet pointed to your public IP address, the same way client will connect to your jvb instance and you need to verify that port forwarding from the public IP address to the private one, works.

Thanks @damencho I will try to do it from outside, but I don’t have alternate internet access.

Can you pls try it from your end as a client and see what is the output/issue?

Many Thanks,
Rav

It says succeed using your command, but make sure you test it with nc client running and listening on the machine with jvb stopped, it can be forwarded to somewhere else…

Thanks @damencho

Just tried using another laptop on a different public IP and it still looks good.

But whatever you are asking me to do is, above my technical capability. :frowning:

Not sure, how to install and run nc client. Should it be on my laptopp or server?
Not sure, how to stop jvb ( is it: sudo service jitsi-videobridge2 stop)?
Not sure, how to “forwarded to somewhere else”. Forward what, where and how?

Many Thanks,
Rav

You should already had done the port forwarding of the ports on your router/NAT device, double check them.

sudo service jitsi-videobridge2 stop
nc -l 10000 -u

And from Internet machine:

echo "123" | nc -u <your public address> 10000

Thanks again.

So this is what I have done:
On the server:
sudo service jitsi-videobridge2 stop
Command ran successfully.
nc -l 10000 -u
Command got stuck, just waiting and nothing happens.

Then on another internet facing machine (but behind firewall, router, antvirus)
	echo "123" | nc -u server.ip.address 10000
		Command ran successfully and prompt came back, but othing happens.

Not sure of I am doing it right or missing something.

BTW I can do the port forwarding on the firewall, but need to know what (which IP, which service, which port) to forward and where?

Many Thanks,
Rav

You should see on the server ‘123’ if port forwarding works.

On your router or nat device that serves your public address you need to port forward udp 10000 to your private address, you had done that already for tcp 443.

I thought so, but I was not sure.
So now, on the server I stopped videbridge2 and then ran “nc -l 10000 -u”, while it was thinking, I went to another laptop (behind firewall, antivirus disabled and with a different static ip address) and ran
echo “123” | nc -u server.ip.address 10000 - bit nothing happened - could not see anythinh anywhere.

Do you want to run the command at your end and I will see if get any message? Can I PM you my public IP?

Just so you know, when 2 ppl chat, it works perfectly fine. But the moment 3rd person joins in, everyone goes for a toss and then the moment someone (1 person) leaves, the other 2 can connect.

So basically it is stuck at 2 people. Any more it goes bonker.

Many Thanks,
Rav

To add a little bit:

I just tried with with 2 ppl in chat, the log has started filling up with “Bridge Channel Send issue” (I thought it only happens when 3 people are in the conference).

Here is the same error:
Logger.js:154 2020-05-22T05:32:08.587Z [modules/RTC/BridgeChannel.js] <l._send>: Bridge Channel send: no opened channel.
Logger.js:154 2020-05-22T05:32:08.587Z [JitsiConference.js] <h.sendMessage>: Failed to send E2E ping request or response. undefined

Logger.js:154 2020-05-22T05:32:18.588Z [modules/RTC/BridgeChannel.js] <l._send>: Bridge Channel send: no opened channel.
Logger.js:154 2020-05-22T05:32:18.590Z [JitsiConference.js] <h.sendMessage>: Failed to send E2E ping request or response. undefined

Logger.js:154 2020-05-22T05:32:19.982Z [modules/RTC/BridgeChannel.js] <l._send>: Bridge Channel send: no opened channel.
Logger.js:154 2020-05-22T05:32:28.588Z [JitsiConference.js] <h.sendMessage>: Failed to send E2E ping request or response. undefined

And with 3rd person, when all of us will loose the video, same errror will fill up (around 30-40 such message) in the console.

If you would like to see full error/log, pls let me know.

Many Thanks,
Rav

This is cause port forward for 443 works, but udp 10000 does not.

This means the packets do not reach jvb, which is why 3 person media does not pass through. This is a network problem you need to solve first before doing any other testing.

Thanks @damencho. Port fixed.

root@meet:~# nc -zvu 1.2.3.4 (My public IP) 10000
Connection to 1.2.3.4 10000 port [udp/*] succeeded!

This is what I get from within as well as outside side the network. If you want to try itr yourself, let me know and I will give you my public IP.

However, the issue still persists. 3 way call is still not working.

Many Thanks,
Rav

But you see the 123 printed when you listen on the jvb machine? This is the way to verify it is working.

No I could not see it… I am still looking into it, but I doubt that will ever happen. :slight_smile: Plus where will I see it? On Command/shell prompt? Will it pop up as a message or a comment?

And what is “nc -l 10000 -u” suppose to do? I am running this command on server and it jiust gets stuck, waiting and nothing happens.

What in “echo “123” | nc -u server.ip.address 10000” the server ip address should be public IP and not the local IP. Right?

You have my public ip, pls feel free to send me a test message.

BTW, if port was an issue, how come first 2 people are able to join? Should it not block everyone? Just curious?

Many Thanks,
Rav

Boom… Got it working. :slight_smile:

Put the command, “echo “Test” | nc -u <my.public.ip.address> 10000” and got the “Test” message displayed on the server.

Glad that we are 1 step further… now what next should I do?

Many Thanks,
Rav

If you have done that from internet then it means port forwarding is working, and jvb should be running fine using that port.

Yeah, going to try it now… If it works, need to check, what I actually did and what was the issue.

Will keep you posted. Pls give me some time.

Many Thanks,
Rav

I just tested your instance and it works with 3 participants.

2 participants work as they are p2p and do not go through the bridge most of the time.

Perfecto… Looks like a dream now. Just tried with 4 friends and myself… 5 people on a mixture of laptop and phone (iOS and Android) and it worked perfectly fine.

However, I am still not sure what changes I made which made port 10000 work - everything seems to be as it is. I will do more digging and if I find some sensible information, I will inform you and everyone here in the group - so that it can help others.

Many Thanks,
Rav

Apologies about my earlier rant about the community support, but this is exactly how it perseved the support to be. This is how it should be - a perfect and very helpful team trying to ensure everyone can get the required help and support so that everyone can use and enjoy the product.

And in return I promise that I will be around to help others based on what I have learnt so far. And also ask more questions as I plan to take this to next level.

Many Thanks,
Rav