Latest Ubuntu package breaks apt

Hi!

On my box I had have self-compiled ngix from source (installed from internal repo)

Recently I got a message, stated that

You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
libnginx-mod-stream : Depends: nginx-common (= 1.16.1-0ubuntu2.1) but it is not installed
nginx : Depends: nginx-core (< 1.16.1-0ubuntu2.1.1~) but it is not installed or
nginx-full (< 1.16.1-0ubuntu2.1.1~) but it is not installed or
nginx-light (< 1.16.1-0ubuntu2.1.1~) but it is not installed o r
nginx-extras (< 1.16.1-0ubuntu2.1.1~) but it is not installed
Depends: nginx-core (>= 1.16.1-0ubuntu2.1) but it is not installed or
nginx-full (>= 1.16.1-0ubuntu2.1) but it is not installed or
nginx-light (>= 1.16.1-0ubuntu2.1) but it is not installed or
nginx-extras (>= 1.16.1-0ubuntu2.1) but it is not installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or speci fy a solution).

If I run ‘apt --fix-broken install’ I have got errors due to I already have nginx installed.

Not sure why is that, here is our nginx dependencies:

I think thats the issue

As I have nginx-full-with-extra, but Jitsi on Ubuntu tries to install nginx package, which tries to overwrite files belonging to nginx-full-with-extra. Apt fail in broken state

Temporarily fixed with
sudo apt-mark hold jicofo jitsi-meet jitsi-meet-prosody jitsi-meet-web jitsi-meet-web-config