Latest Jitsi Meet App freezing on Custom servers

Hello,

Sorry not sure where to post this, mods can put it in the right category!

I have observed a bug with latest compiled Jitsi meet app on Github / App Store / Testflight builds of Jitsi meet app and have noticed the freezing when installing and setting up for the first time before the Enter your name dialog.

Steps to reproduce:

Step 1: Install the App from Appstore / Testflight and make sure you have changed the server url which makes it mandatory to enter your name.

Step 2: Start the meeting, authenticate if needed

Step 3: Now, all of the toolbar controls (Mute switch, Video Switch, More options switch, Hangup switch wont work) because it should technically ask user to enter Name.

Step 4: Force close the App, open the app again and start the meeting now it will ask you for your name and it wont freeze.

What app version did you install? Is your server publicly accessible? I wonder if some specific config values are creating a conflict here.

Hi Saghul,

App from App store as well as Testflight Builds pointed to our servers with requireDisplayName: true,

App Store App Version: 22.1.1
Testflight Build: 22.2.0

Yes, server is publicly accessible and works with older builds of the App.

Thanks for the details! Do you have auth enabled or was there a password set in the room?

Yes, authentication is Prosody.

No password as the bug is reproduced only when authenticating on fresh app install and initial launch and not when meeting attendees join.

Also, was not able to reproduce when joining an ongoing meeting with fresh app install as it doesn’t ask for User authentication and directs user to enter name pop up.

Please let me know if you need any more details.

So, just to be clear: you have auth on and no display name, and the requireDisplayName set to true, correct?

Correct!

App freezes till you input the Name in the dialog, but to get to the dialog you will need to authenticate and then the dialog is presented usually on fresh app install.

Now the bug is:

  1. It doesn’t display the “Enter your name” dialog box and instead freezes the screen forcing you to kill the app.

  2. Then, when you force kill the app and start again the user starts authenticated as the Username and passwords are stored in cache so you don’t need to authenticate again. Then the dialog “Enter your name” is presented and you can proceed without bug.

Now to reproduce the issue second time, you will need to restart the phone before Step 2. there you will find yourself stuck in freezing loop.

(App freezes) only after first time authentication on fresh install of the app till you enter your name. If you force close app and restart the phone, then redo authentication lets say second time it still gets in the freezing loop till you enter the name.

Clear now, thanks!

Thanks for giving us detailed steps! Unfortunately, we still didn’t manage to repro.
Can you send us a screen recording, please?

Also, what beta build number did you test?

I tested using 22.2.0 (1649325101) as the latest 22.2.0 (1649431973) doesn’t let you start the meeting even without any server url it says “You have been disconnected”.

I’m attaching videos in next reply.

@Calinteodor In this video,

  1. I downloaded the app from Testflight 22.2.0 (1649325101) and changed server URL to point to our server.

  2. Entered login information, and the meeting is started. But, it should ask the user to enter the name with pop up dialog which isn’t seen.

  3. Now, you can see that the app is unresponsive as none of the buttons can be used and i had to force close the app.

@saghul This video is after force closing the app (not restarting the phone), the authentication data is in cache so it directly pops up to “Enter your name” dialog and all the toolbar buttons are working.

If i would have restarted the phone to clear the authentication cache, it would have stuck in the same loop as the first video above.

Let me know if you require any more details, i’m happy to provide!

Let me kick off some betas as the last one is botched. Also, I cannot see your videos, it looks like an audio file for some reason.

Sure!

You can download the video and play. There is an option to download in more options (Three Vertical dots)

If you are still not able to play let me know i’ll share somewhere else and give the link.

We pushed a new beta yesterday, can you please give it a try?

This problem is solved.

But the problem mentioned in topic persists!

This I cannot reproduce. Any chance you can provide us with some test credentials to your server please?

I’ve sent you a PM!

Hi Saghul,

Were you able to test this with the credentials to my server?