Latest jibri not working


#1

Hi All,
I would like to know if anyone else having trouble recording / streaming using latest jibri. previously, I was using 5.0.57-1 and it was working fine. but recently, after updating packages jibri-6.0.59-1 stopped working. I mean when I checked the service status it shows jibri is running. but when I click recording button, it says “all jibri are busy”. I even tried with my own latest jitsi deployment and it is still not working. However when I downgraded the package to 5.1.58-1 it started working.

  1. How to solve this issue?
  2. also I would like to know, how can I transfer the file to my file(samba) server? I saw in the config file there is an option finalize_recording_script_path but not sure how ? can anyone give an example shell script to do this task??

#2

Changes were recently made to Jibri to make failures “persist” so that, if Jibri has an issue during one recording/stream we don’t select it again after that one is over. It’s possible you’re seeing something related to that. Can you attach your jibri logs?


#3

Hi @bbaldino,
Thanks for reply. here is the logs. I have changed my domain name in the logs though. hope thats ok. I am using secure domain btw,

Jibri versions,
OS: Ubuntu 16.04.5 LTS
Jibri: 6.0.59-1
Chrome: 70.0.3538.77
ChromeDriver: 2.43.600233

  1. JS console log
  2. Jicofo log
  3. Jibri log

#4

Nothing jumping out there, but, did you upgrade Jicofo as well as Jibri? The Jibri changes are not backwards compatible, so both Jicofo and Jibri need to be upgraded.


#5

I see I will give it a try after update