LAN-only jitsi-meet installation: Video/audio not working

Hello everyone,

I am trying to install jitsi-meet on a server on my LAN to use as a baby monitor. For that usecase I really do not want to have this accessible from outside the LAN itself.

I have successfully installed it on a VirtualBox VM with a bridged adapter (no NAT) and I can connect and create meetings following the Ubuntu quickstart guide. However, no user can see/hear anyone else and I am not sure where is the problem exactly.

Any relevant threads I can find mention fixing NAT issues, which don’t seem applicable in my case as I am connecting directly to the server using a (local) static ip.

Any suggestion/idea would be really appreciated :slight_smile:

you can’t use Jitsi-meet using a static IP.
While you are using it only locally, Jitsi-meet is aimed at Internet use, it is based on a browser feature, Webrtc. Browsers makers have all decided that managed peripherals can be used only with https (because http connections are open to third party hijacking), and https can only really be used with names, not naked IP addresses. That’s not something that Jitsi-meet can on even will to override for very marginal case.
So to use Jitsi-meet you have to:

  • use an internal dns server (best option IMO) or fiddle with host files
  • define at least a self-signed certificate
  • set it up on the server with a name coherent with your host files or internal dns server
  • accept all sorts of unsavoury warnings and nasty remarks from your browser when you will try to coerce it to accept the self signed certificate.

If all this seems to much a hassle, and it is for your use case, you have always the option to buy a box for about 50$ or 50€ that will allow you to check out what happens to your child just as well.