Kubernetes : "Something went wrong" loop

Hello,

First of all, I’ve been using a self hosted Jitsi on a single VM for two years now, it’s an amazing software, way better than many proprietary conference tools !

I’m now trying to host it on my Kubernetes cluster, and I have a problem.
I can connect to a room, but if anyone else connect to the same room, we immediately enter the “something went wrong” loop. I’ve tried many configurations, nothing helps.

Jicofo 2019-08-09 14:25:18.376 INFO: [36] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Member tinysnakesswimstrangely@muc.meet.jitsi/olud4_g6 joined.
Jicofo 2019-08-09 14:25:18.386 SEVERE: [36] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Can not invite participant – no bridge available.
Jicofo 2019-08-09 14:25:18.387 SEVERE: [36] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Can not invite participant – no bridge available.
Jicofo 2019-08-09 14:25:19.592 INFO: [36] org.jitsi.jicofo.ChatRoomRoleAndPresence.log() Chat room event ChatRoomMemberPresenceChangeEvent[type=MemberLeft sourceRoom=org.jitsi.impl.protocol.xmpp.ChatRoomImpl@3922d197 member=ChatMember[tinysnakesswimstrangely@muc.meet.jitsi/ci46dzge, jid: ci46dzgerfgy_wvd@meet.jitsi/UMABwVVp]@1404544795]
Jicofo 2019-08-09 14:25:19.592 INFO: [36] org.jitsi.jicofo.ChatRoomRoleAndPresence.log() Owner has left the room !
Jicofo 2019-08-09 14:25:19.595 INFO: [36] org.jitsi.jicofo.ChatRoomRoleAndPresence.log() Granted owner to tinysnakesswimstrangely@muc.meet.jitsi/olud4_g6
Jicofo 2019-08-09 14:25:19.595 INFO: [36] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Member tinysnakesswimstrangely@muc.meet.jitsi/ci46dzge is leaving
Jicofo 2019-08-09 14:25:19.596 INFO: [36] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Removed participant: true, tinysnakesswimstrangely@muc.meet.jitsi/ci46dzge

The most important log seems to be “org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Can not invite participant – no bridge available.”, but I have no idea why it says that. I’ve checked that all my pods can resolve names (‘prosody’ for example resolves to the correct IP).

I’ve uploaded jvb, prosody and jicofo logs. I’ve only changed my public IP to X.X.X.X.

Logs are from cluster creation to one room created with 2 participants.

Please help :slightly_smiling_face: :slightly_smiling_face:

I suspect your jvb has not be able to connect to the xmpp server and the control room:

JVB 2019-08-09 14:23:52.209 SEVERE: [48] org.jitsi.xmpp.mucclient.MucClientManager.log() Failed to initialize and start a MucClient: 
org.jivesoftware.smack.sasl.SASLErrorException: SASLError using SCRAM-SHA-1: malformed-request
	at org.jivesoftware.smack.SASLAuthentication.authenticationFailed(SASLAuthentication.java:291)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1096)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:994)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1010)
	at java.lang.Thread.run(Thread.java:748)

Good catch ! Thanks to your hint, I have fixed the problem.
For some reason, “default” environment variables are not used in my pods at all. I had to redefine all of the variables in the “Advanced configuration” section, for all deployments.
Now it works, thank you very much :slightly_smiling_face: