K8s helm branch

@Aaron_K_van_Meerten I was just curious why have you not merget the K8s-helm branch on the docker-jitsi-meet repository yet? Will it get merged soon?

Thanks for the ping, this had not been on my radar anymore. I’ll review it again with @saghul and we’ll discuss the next steps. This was meant as a proof of concept rather than a reliable production deployment method, so we’ll still want community support in testing and updating it too. Our team has learn many valuable lessons about running services in k8s since this was originally written, so likely there’s already improvements that can be made before an initial merge. Thanks again for the ping, and I hope to update you soon, likely after this holiday week is complete.

1 Like

Thank you for replying @Aaron_K_van_Meerten, just one question for the already existing implementation. I just started learning Kubernetes so it might be a stupid question, but do I need an Ingress controller for this implementation to work or not? I want to be able to access the app with https through its domain name on my private network, and I created a secret resource with my certificate and key. I also configured the values.yaml in this way:

...
ingress:
  enabled: true
  annonations: {}
  paths: ["/"]
  hosts:
    - mydomain.com
  tls:
    - secretName: jitsi-tls
      hosts:
        - mydomain.com
...

however when I run the cluster with helm, “helm install k8s” I can only access the app through IP address and not domain name. When I run “kubectl describe ingress/webingress” it shows this:

...
Address:
Default backend: default-http-backend:80 (<none>)
TLS:
  jitsi-tls terminates mydomain.com
Rules:
Host                      Path   Backends
----                      ----   --------
mydomain.com              /      web:http (10.12.55.90:80)
...

Address field is empty?!

Anyone going through the same problems check here:
https://kubernetes.github.io/ingress-nginx/deploy/
Install for bare metal and then check:
https://kubernetes.github.io/ingress-nginx/deploy/baremetal/