Jxs raising 404, even on unsecured default Debian Jitsi install

I’m trying to use “GitHub - jitsi/jxs”. It looks like only service and domain are used in the config. I have a default unsecured Debian config that I’m trying to use jxs with:

{
    "service": "wss://meet.testing-8.madrubyscience.com/xmpp-websocket",
    "domain": "meet.testing-8.madrubyscience.com"
}

The URL is what you see there: meet.testing-8.madrubyscience.com (you can have a look if you like.) The Jitsi install basically works and has no authentication in place. But jxs appears to be getting a 404 on an HTTP GET (‘wss://meet.testing-8.madrubyscience.com/xmpp-websocket?room=jxs-test-16204013042114294-0’). The randomised room number makes sense with what jxs does, of course.

I checked the config files on that Jitsi installation in /etc/jitsi, and the domain seems right. Here’s part of /etc/jitsi/meet/meet.testing-8.madrubyscience.com-config.js, for instance:

var config = {
    // Connection
    //

    hosts: {
        // XMPP domain.
        domain: 'meet.testing-8.madrubyscience.com',

        // When using authentication, domain for guest users.
        // anonymousdomain: 'guest.example.com',

        // Domain for authenticated users. Defaults to <domain>.
        // authdomain: 'meet.testing-8.madrubyscience.com',

        // Focus component domain. Defaults to focus.<domain>.
        // focus: 'focus.meet.testing-8.madrubyscience.com',

        // XMPP MUC domain. FIXME: use XEP-0030 to discover it.
        muc: 'conference.<!--# echo var="subdomain" default="" -->meet.testing-8.madrubyscience.com'
    },

Any suggestions about what I could be doing wrong?

Is your deployment setup to use websockets? Seems jxs works only when the deployment uses websocket instead of bosh for the signaling.

Yes, uses websockets.

Nope, your deployment is using just bosh:

     // Websocket URL
    // websocket: 'wss://meet.testing-8.madrubyscience.com/xmpp-websocket',

To enable this, you need to enable some extra modules and settings … there should be a post in the forum how to do that … let me check

Weird. Okay, thanks for checking!