JWT with Token and Screensharing

Hello all,
Participants do not see the share when we enable JWT with authentication = “token,”
but works with authentication = “anonymous”
Any idea what we’re missing? Do we have to add something in the token body?

Edit: do you mean the screenshare option is not there, or you can enable screenshare but nobody sees it? My original post assumed the former.


Do you have enableFeaturesBasedOnToken: true in your config.js?

If so, then you can either disable that or add that feature to tokens for people you want to allow screenshare for. See:

1 Like

my config: // enableFeaturesBasedOnToken: false,
screenshare is available. Everyone can screenshare but no one sees the shared document.
I will try
“features”: {
“screen-sharing”: true
}

Thanks, Shawn.
Confirming JWT token feature: screen-sharing”: true. Is what is needed

1 Like