JWT token authorization fails when room name is a regex

I think I found a bug, then I create an issue.
But I’m not sure how to modify this line of code, please help, thank you!

Please stick to first discussing issues in the forum before opening them. Thank you.
@Andrei_Bora any idea?

FYI, JWT auth using room regex works as expected for me. I’m on latest stable jitsi-meet (2.0.7882).

Edit: It looks like regex based matching only done if enable_domain_verification is enabled, which I do have. A workaround might be to enabled that, and set "sub": "*" if you are not able to make that match actual domain.

1 Like

I add ‘enable_domain_verification = true’ in prosody.cfg.lua and it works, thank you!