JWT Simply Doesn't Work on Docker

Or if it does, please tell me what I’m missing or misunderstanding. I’m running a fresh install of stable-5142. Here’s my configuration…

Config 1

With JWT enabled, guests disabled, and JWT_ALLOW_EMPTY=0, absolutely anyone can join the conference without a JWT. No errors appear in the console. It’s as if authentication is not even enabled. Here’s my .env

# Enable authentication
ENABLE_AUTH=1

# Enable guest access
#ENABLE_GUESTS=1

# Select authentication type: internal, jwt or ldap
AUTH_TYPE=jwt

# JWT authentication
#

# Application identifier
JWT_APP_ID=my_jitsi_app_id

# Application secret known only to your token
JWT_APP_SECRET=xxxxxx

# (Optional) Set asap_accepted_issuers as a comma separated list
JWT_ACCEPTED_ISSUERS=my_web_client,my_app_client

# (Optional) Set asap_accepted_audiences as a comma separated list
JWT_ACCEPTED_AUDIENCES=my_server1,my_server2

# Allow anonymous users with no JWT while validating JWTs when provided
JWT_ALLOW_EMPTY=0

Config 2

And just as confusingly, if I do allow guests and in the URL put ?jwt=blah, then an error appears in the console, but the user is still allowed into the conference anyway. :confused:

# Enable authentication
ENABLE_AUTH=1

# Enable guest access
ENABLE_GUESTS=1

# Select authentication type: internal, jwt or ldap
AUTH_TYPE=jwt

# JWT authentication
#

# Application identifier
JWT_APP_ID=my_jitsi_app_id

# Application secret known only to your token
JWT_APP_SECRET=xxxxx

# (Optional) Set asap_accepted_issuers as a comma separated list
JWT_ACCEPTED_ISSUERS=my_web_client,my_app_client

# (Optional) Set asap_accepted_audiences as a comma separated list
JWT_ACCEPTED_AUDIENCES=my_server1,my_server2

# Allow anonymous users with no JWT while validating JWTs when provided
JWT_ALLOW_EMPTY=0

Anyone have any idea what’s going on here?