JWT does not work

Hi,

I am try to use the JWT, but it does not work. Jitsi was installed on Ubuntu Server.
When I try to open a room, the camera can not work.

My config:

VirtualHost "meet.lohr.com.br"
    authentication = "token";
    app_id = "meet";                
    app_secret = "****"   
    allow_empty_token = true

    ssl = {
            key = "/etc/prosody/certs/meet.lohr.com.br.key";
            certificate = "/etc/prosody/certs/meet.lohr.com.br.crt";
    }
    speakerstats_component = "speakerstats.meet.lohr.com.br"
    conference_duration_component = "conferenceduration.meet.lohr.com.br"
    -- we need bosh
    modules_enabled = {
        "bosh";
        "pubsub";
        "ping"; -- Enable mod_ping
        "speakerstats";
        "turncredentials";
        "conference_duration";
        "muc_lobby_rooms";
    }
    c2s_require_encryption = false
    lobby_muc = "lobby.meet.lohr.com.br"
    main_muc = "conference.meet.lohr.com.br"

Thanks

Hello @carlosalbanaz,

  • Before the JWT, did it work?

  • Does it work with allow_empty_token = true?

  • What is the status?

systemctl status prosody

Hello @emrah

Does it work with allow_empty_token = true ?
No. It doen’t.

I couldn’t see the error:

prosody.service - Prosody XMPP Server
 Loaded: loaded (/lib/systemd/system/prosody.service; enabled; vendor preset: enabled)
 Active: active (running) since Fri 2020-11-20 16:42:02 UTC; 29min ago
   Docs: https://prosody.im/doc
  Main PID: 27380 (lua5.2)
  Tasks: 1 (limit: 65000)
 Memory: 19.0M
 CGroup: /system.slice/prosody.service
         └─27380 lua5.2 /usr/bin/prosody

Nov 20 16:42:02 meet.lohr.com.br systemd[1]: Started Prosody XMPP Server.
Nov 20 16:42:02 meet.lohr.com.br prosody[27380]: modulemanager: Error initializing module 'auth_token' on 'meet.lohr.com.br': /usr/lib/prosody/util/startup.lua:145: module 'basexx' not found:No LuaRocks module found f>
                                                     no field package.preload['basexx']
                                                     no file '/usr/lib/prosody/basexx.lua'

You need to fix those, check prosody logs for errors it is in /var/log/prosody

Whare are the outputs

dpkg -l prosody
cat /etc/apt/sources.list
cat /etc/apt/sources.list.d/*

I will try to use Jitsi - Docker. I think it is more simple.

Thnks a lot.

I created two docs with how to install jitsi meet + jwt on ubuntu 18 and 20 (with video)

https://github.com/christiancuri/Docs