JWT Authentication

Hi, I was able in install jitsi with regular (internal_plain) authentication, works great. Now when I am adding the JWT token authentication I am getting this error. Any help?

$ apt-get install jitsi-meet-tokens
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
jitsi-meet-tokens : Depends: prosody-trunk (>= 1nightly747) but it is not installable or
prosody-0.11 but it is not installable or
prosody (>= 0.11.2)
E: Unable to correct problems, you have held broken packages.

I was following: https://github.com/mjtiempo/Docs/blob/master/Jitsi%20Meet%20Installation.md

Thanks!

what is the output?

dpkg -l "prosody*"

Thanks Enrah.

root@meet:~# dpkg -l “prosody*”
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
++±=========================================-=========================-=========================-========================================================================================
ii prosody 0.10.0-1build1 amd64 Lightweight Jabber/XMPP server
un prosody-0.11 (no description available)
un prosody-modules (no description available)
un prosody-trunk (no description available)
root@meet:~#

The current jitsi-meet-tokens needs prosody which is newer than 0.11. You have already installed one but it’s older. First of all you need to upgrade your prosody version.

@corby has a topic about this

Thank you. Installed it and it worked like a charm. Thank you!
root@meet:~# dpkg -l “prosody*”
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
++±======================================-========================-========================-=================================================================================
ii prosody 0.11.5-1~bionic6 amd64 Lightweight Jabber/XMPP server
un prosody-0.11 (no description available)
un prosody-modules (no description available)
un prosody-trunk (no description available)
un prosody-xmpp-server (no description available)