JWT authentication issue

I’m trying to configure a Jitsi Meet setup to use JWT authentication; I’ve followed the guide for setting up and everything appears to be installed and configured correctly (prosody-trunk build 747, jitsi-meet-tokens installs etc.), however prosody doesn’t seem to be getting the token that I am passing in the URL, reporting an error as follows:

general warn Error verifying token err:not-allowed, reason:token required
I am passing the token in the URL as https://HOSTNAME/ROOMNAME?jwt=

Is any modification needed in nginx settings?

Any help will be greatly appreciated.

@damencho could you provide any pointers please?