Jwt authentication bug


#1

Hello,

I have previously successfully implemented jwt authentication on a Ubuntu 16.04. The version of Jitsi meet was 1.0.3229-1 I used these following command

    1  sudo apt-get update
    2  sudo apt-get install nginx
    3  sudo sh -c "echo 'deb https://download.jitsi.org stable/' > /etc/apt/sources.list.d/jitsi-stable.list"
    4  wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | sudo apt-key add -
    5  sudo apt-get update
    6  sudo apt-get -y install jitsi-meet
    11  sudo /etc/init.d/jicofo reload
    12  sudo /etc/init.d/jicofo restart
    13  sudo /etc/init.d/jitsi-videobridge reload
    14  sudo /etc/init.d/jitsi-videobridge restart
    15  sudo /etc/init.d/prosody reload
    16  sudo /etc/init.d/prosody restart
    17  sudo wget https://packages.prosody.im/debian/pool/main/p/prosody-trunk/prosody-trunk_1nightly1001-1~xenial_amd64.deb
    18  sudo dpkg -i prosody-trunk_1nightly1001-1~xenial_amd64.deb
    19  lsb_release
    20  sudo dpkg --print-architecture
    22  sudo apt-get install jitsi-meet-tokens
    23  sudo nano /etc/prosody/prosody.cfg.lua
    24  sudo /etc/init.d/jicofo reload
    25  sudo /etc/init.d/jicofo restart
    26  sudo /etc/init.d/jitsi-videobridge reload
    27  sudo /etc/init.d/jitsi-videobridge restart
    28  sudo /etc/init.d/prosody reload
    29  sudo /etc/init.d/prosody restart
    30  history

When I run lsb_release -a I got the following

No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 16.04.5 LTS
Release:	16.04
Codename:	xenial

I tried yesterday to do the same with a clean Ubuntu 16.04, all the command pass but I can’t connect to a room using a jwt.I used jwt through url like this https://serveur/test?jwt=eyJ0eXAiO

I tried to debug my new installation without success : JWT: token required

I am wondering if this is a problem with a recent change in Jitsi or if I’m just doing something wrong.


#2

Try using prosody 747, known to work.


#3

It worked, you’re the best. Thanks