JWT auth not working

Hi, I’m a newbee to jitsi and web-programming. I’ve installed jitsi-meet on my linux mint VM according to this guide. Everything is okay. After this i’ve tried to install jwt authorization according to this. When i’m trying to access any room without any token i don’t get any error messages. It’s seems to me that the connection has not been established and anything in the room does not work (no voice, no video,no chat).


When explicitly pass in the jwt token generated by jwt.io like this,
https://media.discordapp.net/attachments/694448045131169793/694468472528437288/unknown.png?width=838&height=670
I got the same result but with some auth data.
https://media.discordapp.net/attachments/694448045131169793/694468390009569281/unknown.png?width=1440&height=626
Thanks in advance.

Have you checked prosody for errors?

There is this repeating error in prosody.log and prosody.err

This is wrong storage param in prosody config, trunk is “null”, 0.9 is “none”, 0.11 is “memory”.

Thanks :blush:. I’ve checked prosody config and changed storage = 'internal' (however it should be ‘iternal’ as default but for some reason it’s not) :thinking:. Then i got the error : “basexx is not installed” in prosody.err. I have installed it via luarocks install basexx and followed this topic to fix other errors. Now when a user comes without a token, he receives a pop-up window ‘Password required’. If i pass in the jwt token that i attached before as url parameter i get pop-up ‘Authentication failed’ window. :disappointed_relieved: How do i make my app validate tokens correctly? And can i change the ‘Password required’ window to something like ‘You are not authorized’ (because if a user tries to access the page without the token, he will try to authorize in this window(but not in the external service as i want) and thus token will not be generated)?

@damencho, pls help. :pleading_face: I haven’t managed to solve the problem, i described above. Thank you for your support.

You were able to deploy this jwt auth? I also need some help. I installed everything and it seems, i am also facing problem same as yours.

I am not able to set up jwt token, prosody.log

Replace in that file(mod_auth_token.lua) hook_global_global with hook_global.
I think this issue was fixed at some point.