JVB: How to listen to port 443


#1

So I have an fresh install of Ubuntu 16.0.4, and doesn’t have port TCP 443 listening yet. I then installed only jitsi-videobridge and it still falls back to TCP port 4443.

The error is

org.jitsi.videobridge.IceUdpTransportManager.log() Failed to initialize TCP harvester on port 443: java.net.SocketException: Permission denied. Retrying on port 4443.

I also added: org.ice4j.ice.harvest.TCP_HARVESTER_PORT=443

And still doesn’t work.

I’d like to put configure jvb on port 443 so I don’t have to map it externally from 443 to 4443.

Thanks!


#2

You need to install and configure authbind to allow jvb user to start a process on privileged port (<1024).
Here is how jitsi-meet does it https://github.com/jitsi/jitsi-meet/blob/master/debian/jitsi-meet-web-config.postinst#L139


#3

Thank you, it worked. To enable authbind, I did the following on Ubuntu 16.0.4.

  • On JVB server, make sure that 443 is not being used.
  • Add the following in /etc/jitsi/videobridge/config:
    AUTHBIND=yes
  • Enable authbind
    • Find user user to run jvb. It should be jvb, but you can run the following to know for sure: stat -c '%U' /usr/share/jitsi-videobridge
    • mkdir -p -m755 /etc/authbind/byport
    • touch /etc/authbind/byport/443
    • chmod 755 touch /etc/authbind/byport/443
    • chown jvb /etc/authbind/byport/443
    • restart jitsi-videobridge