Jvb gracefull shutdown

when jvb gracefull shutdown it gives below response
Invalid HTTP status for shutdown request: 503

how to do it. I have enabled rest and xmpp services.

Are you doing that using the graceful_shutdown.sh? If you are doing your own rest are you using http://localhost:8080 to connect?

@damencho yes I have run graceful_shutdown.sh script and i also active xmpp,rest api in jvb. currently, http://localhost:8080/colibri/stats is working

Ha you need to enable it “org.jitsi.videobridge.ENABLE_REST_SHUTDOWN=true”, just took a look at the code … https://github.com/jitsi/jitsi-videobridge/blob/c7e345c29a60e9cd88ab50071e9a714f7a0625a3/src/main/java/org/jitsi/videobridge/rest/HandlerImpl.java#L1079

thank you very much @damencho

I have enabled

and I get the colibri/stats, however when trying to gracefully shutdown it shows me

Invalid HTTP status for shutdown request: 401

hi, same here using stable or unstable release.

with :
org.jitsi.videobridge.ENABLE_REST_SHUTDOWN=true

i can:
curl -s 127.0.0.1:8080/colibri/stats

but cant:

curl -s -H “Content-Type: application/json” -d ‘{ “graceful-shutdown”: “true” }’ -w “%{http_code}” “127.0.0.1:8080/colibri/shutdown”

Error 503 Service Unavailable

HTTP ERROR 503

Problem accessing /colibri/shutdown. Reason:

    Service Unavailable

Powered by Jetty:// 9.4.15.v20190215

what i forgot ?

same error

We need :

authorize shutdown from localhost only

org.jitsi.videobridge.ENABLE_REST_SHUTDOWN=true
org.jitsi.videobridge.shutdown.ALLOWED_SOURCE_REGEXP=127.0.0.1

works :slight_smile:

1 Like

On my system I had to escape the dots in the IP-address as mentioned here.