JVB Error: Invalid message received (Parameter specified as non-null is null..)

Hey Everyone,

I am seeing this message on my docker-jitsi-meet (latest) deployment spamming my logs with this message. I’m trying to force 1080p with VP9 or H264 and was wondering if it’s because of that?

Thanks

WARNING: Invalid message received (Parameter specified as non-null is null: method org.jitsi.videobridge.message.EndpointStats.put, parameter value (through reference chain: org.jitsi.videobridge.message.EndpointStats["connectionQuality"]): {"colibriClass":"EndpointStats","bitrate":{"upload":136,"download":217,"audio":{"upload":1,"download":0},"video":{"upload":135,"download":217}},"packetLoss":{"total":0,"download":0,"upload":0},"connectionQuality":null,"jvbRTT":2,"maxEnabledResolution":180}

1 Like

Hi!

We are facing the same warning with Jitsi docker images, specifically with the version 6433. We have also a problem that we can see only two videos at a meeting, even though there are 3 or more participants.

Have you able to solve the issue?

This was fixed by setting maxBitratesVideo in config.js. The default docker image deployment has only empty object.

if (!config.videoQuality.hasOwnProperty(‘maxBitratesVideo’)) config.videoQuality.maxBitratesVideo = {};
config.videoQuality.maxBitratesVideo.H264 = { low: 200000, standard: 500000, high: 1500000 };
config.videoQuality.maxBitratesVideo.VP8 = { low: 200000, standard: 500000, high: 1500000 };
config.videoQuality.maxBitratesVideo.VP9 = { low: 100000, standard: 300000, high: 1200000 };