JVB broken after upgrade

Hi,

I’ve had a self-hosted jitsi instance on a Debian 10 with a public IP. It was working great.
I’ve upgraded the packages this morning, and since then I have to audio/video in my meetings.
I have not changed my firewall configuration after the upgrade.

I have some errors like this :

2020-05-01 17:41:55.176 INFO: [70] Videobridge.createConference#320: create_conf, id=209a9ed72ea76096 gid=ff3dd2 logging=true
2020-05-01 17:41:55.180 INFO: [70] [confId=209a9ed72ea76096 epId=066c8235 local_ufrag=be7oj1e78edfjb gid=ff3dd2 conf_name=jlecour ufrag=be7oj1e78edfjb] Agent.gatherCandidates#662: Gathering candidates for component stream-066c8235.RTP.
2020-05-01 17:41:55.220 INFO: [74] [confId=209a9ed72ea76096 gid=ff3dd2 conf_name=jlecour] Conference.dominantSpeakerChanged#446: ds_change ds_id=066c8235
Exception in thread "Smack Cached Executor" java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.videobridge.sctp.SctpManager
	at org.jitsi.videobridge.Endpoint.createSctpConnection(Endpoint.java:868)
	at org.jitsi.videobridge.shim.ContentShim.createSctpConnection(ContentShim.java:167)
	at org.jitsi.videobridge.shim.ContentShim.getOrCreateSctpConnectionShim(ContentShim.java:359)
	at org.jitsi.videobridge.shim.VideobridgeShim.processSctpConnections(VideobridgeShim.java:214)
	at org.jitsi.videobridge.shim.VideobridgeShim.handleColibriConferenceIQ(VideobridgeShim.java:377)
	at org.jitsi.videobridge.Videobridge.handleColibriConferenceIQ(Videobridge.java:600)
	at org.jitsi.videobridge.Videobridge.handleColibriConferenceIQ(Videobridge.java:585)
	at org.jitsi.videobridge.xmpp.XmppCommon.handleIQRequest(XmppCommon.java:228)
	at org.jitsi.videobridge.xmpp.XmppCommon.handleIQInternal(XmppCommon.java:179)
	at org.jitsi.videobridge.xmpp.XmppCommon.handleIQ(XmppCommon.java:150)
	at org.jitsi.videobridge.xmpp.ClientConnectionImpl.handleIq(ClientConnectionImpl.java:108)
	at org.jitsi.xmpp.mucclient.IQListener.handleIq(IQListener.java:50)
	at org.jitsi.xmpp.mucclient.MucClient.handleIq(MucClient.java:547)
	at org.jitsi.xmpp.mucclient.MucClient.access$500(MucClient.java:50)
	at org.jitsi.xmpp.mucclient.MucClient$2.handleIQRequest(MucClient.java:511)
	at org.jivesoftware.smack.AbstractXMPPConnection$4.run(AbstractXMPPConnection.java:1188)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:834)
2020-05-01 17:41:56.665 SEVERE: [30] AbstractHealthCheckService.run#174: Health check failed in PT0.00004S:
java.lang.Exception: Address discovery through STUN failed
	at org.jitsi.videobridge.health.Health.performCheck(Health.java:195)
	at org.jitsi.health.AbstractHealthCheckService.run(AbstractHealthCheckService.kt:144)
	at org.jitsi.utils.concurrent.RecurringRunnableExecutor.run(RecurringRunnableExecutor.java:216)
	at org.jitsi.utils.concurrent.RecurringRunnableExecutor.runInThread(RecurringRunnableExecutor.java:292)
	at org.jitsi.utils.concurrent.RecurringRunnableExecutor.access$000(RecurringRunnableExecutor.java:36)
	at org.jitsi.utils.concurrent.RecurringRunnableExecutor$1.run(RecurringRunnableExecutor.java:328)
2020-05-01 17:42:06.666 SEVERE: [30] AbstractHealthCheckService.run#174: Health check failed in PT0.000072S:

I’ve replaced the Google STUN servers in the config file for Jitsi’s. But it doesn’t change anything.

My /tmp partition was mounted in “noexec” mode after reboot. Putting it back to “exec” and restarting the jvb server fixed it.